Prevent NVIDIA Driver from switching display automatically

Hello there,

i’m using linux on a laptop with an GF108M [GeForce GT 525M] graphics chip and the nvidia driver 319.60 under Ubuntu 13.10.

The laptop is connected to a tv with hdmi. I configured the laptop so, that the tv is the only display used and the internal display is disabled. The laptop is used as a server and should run all the time.

Now, when I turn of the tv, the nvidia driver seems to automatically switch to the internal display, because the tv has gone. I don’t want this. I don’t want the internal display to be used at all in any case. Can I disable that automatic behaviour somehow?

The problem first came up after I from Ubuntu 12.10 with an old nvidia driver (I don’t know the exact version), to Ubuntu 13.10 with a more recent nvidia driver. Before that, there was no automatic switching.

Thanks in advance for any help
lonavera

The nvidia driver does not automatically reconfigure the screen. Usually, that sort of behavior comes from gnome-settings-daemon or some other application provided by your desktop environment. If gnome-settings-daemon is running, does killing it help?

I’m using Kubuntu with KDE Desktop. I have disconnected the internal display from my laptop to prevent automatic switching. No matter what causes the switching it is horribly anoing:(

But now I have another problem. Some component switches the resolution automatically from 1080p to 720p. I have no Idea who is causing that, but in the log there are some output, that makes me think about the nvidia driver again:

Xorg.0.log

< [ 1801.807] () NVIDIA(0): device ONKYO Corporation TX-NR609 (DFP-1) (Using EDID
< [ 1801.807] (
) NVIDIA(0): frequencies has been enabled on all display devices.)
< [ 1801.870] (II) NVIDIA(GPU-0): Display (ONKYO Corporation TX-NR609 (DFP-1)) does not support
< [ 1801.870] (II) NVIDIA(GPU-0): NVIDIA 3D Vision stereo.
< [ 1801.870] () NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
< [ 1801.870] (
) NVIDIA(0): device ONKYO Corporation TX-NR609 (DFP-1) (Using EDID
< [ 1801.870] () NVIDIA(0): frequencies has been enabled on all display devices.)
< [ 1802.190] (II) NVIDIA(0): Setting mode “HDMI-0: 1280x720 @1280x720 +0+0 {ViewPortIn=1280x720, ViewPortOut=1280x720+0+0}”
< [ 1802.419] (II) NVIDIA(GPU-0): Display (ONKYO Corporation TX-NR609 (DFP-1)) does not support
< [ 1802.419] (II) NVIDIA(GPU-0): NVIDIA 3D Vision stereo.
< [ 1802.419] (
) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
< [ 1802.419] () NVIDIA(0): device ONKYO Corporation TX-NR609 (DFP-1) (Using EDID
< [ 1802.419] (
) NVIDIA(0): frequencies has been enabled on all display devices.)
< [ 1802.512] (II) NVIDIA(GPU-0): Display (ONKYO Corporation TX-NR609 (DFP-1)) does not support
< [ 1802.512] (II) NVIDIA(GPU-0): NVIDIA 3D Vision stereo.
< [ 1802.512] () NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
< [ 1802.512] (
) NVIDIA(0): device ONKYO Corporation TX-NR609 (DFP-1) (Using EDID
< [ 1802.512] (**) NVIDIA(0): frequencies has been enabled on all display devices.)
< [ 1802.557] (II) NVIDIA(GPU-0): Display (ONKYO Corporation TX-NR609 (DFP-1)) does not support

The nvidia driver just prints those log messages when a monitor is plugged it, and when setting a mode. However, it doesn’t set modes on its own; it’s doing it at the request of an X client. I’m not too familiar with how KDE handles its automatic display configuration stuff, but you might want to look through the KDE control panel to see if you can find the monitor resolution settings there.