Problem installing driver 418.67-1.0-1 on centOS 7

Hi everyone, I post this message because I have some troubles installing Nvidia drivers 418.67-1.0-1
(file nvidia-diag-driver-local-repo-rhel7-418.67-1.0-1.x86_64.rpm from this link : https://www.nvidia.fr/content/DriverDownload-March2009/confirmation.php?url=/tesla/418.67/nvidia-diag-driver-local-repo-rhel7-418.67-1.0-1.x86_64.rpm&lang=fr&type=Tesla)

I previously tried to install using Elrepo nvidia-detect and kmod-nvidia drivers without success. After a clean uninstall I sticked to the official drivers and launched nvidia-bug-report.sh you will find attached.

Here are few usefull commands :

[root@wqya0749 ~]# rpm -q centos-release
centos-release-7-6.1810.2.el7.centos.x86_64
[root@wqya0749 ~]# uname -rs
Linux 3.10.0-957.21.3.el7.x86_64
[root@wqya0749 ~]# lspci | grep 3D
13:00.0 3D controller: NVIDIA Corporation GV100GL [Tesla V100 PCIe 16GB] (rev a1)
[root@wqya0749 ~]# rpm -qa kernel
kernel-3.10.0-957.21.3.el7.x86_64
[root@wqya0749 ~]# yum list | grep kernel
abrt-addon-kerneloops.x86_64       2.1.11-52.el7.centos
kernel.x86_64                      3.10.0-957.21.3.el7
kernel-debug-devel.x86_64          3.10.0-957.21.3.el7
kernel-headers.x86_64              3.10.0-957.21.3.el7
erlang-kernel.x86_64               R16B-03.18.el7    La_Poste_EPEL_EPEL_7
kernel-abi-whitelists.noarch       3.10.0-957.21.3.el7
kernel-debug.x86_64                3.10.0-957.21.3.el7
kernel-devel.x86_64                3.10.0-957.21.3.el7
kernel-doc.noarch                  3.10.0-957.21.3.el7
kernel-tools.x86_64                3.10.0-957.21.3.el7
kernel-tools-libs.x86_64           3.10.0-957.21.3.el7
kernel-tools-libs-devel.x86_64     3.10.0-957.21.3.el7
libreport-plugin-kerneloops.x86_64 2.1.11-42.el7.centos
lirc-disable-kernel-rc.noarch      0.10.0-16.el7     La_Poste_EPEL_EPEL_7
php-symfony-http-kernel.noarch     2.8.12-2.el7      La_Poste_EPEL_EPEL_7
texlive-l3kernel.noarch            2:svn29409.SVN_4469-43.el7
texlive-l3kernel-doc.noarch        2:svn29409.SVN_4469-43.el7

nvidia-bug-report.log (544 KB)

The nouveau driver is loaded, please blacklist it manually (don’t know why the driver package didn’t do it). E.g. create a file /etc/modprobe.d/nouveau-blacklist.conf with contents

blacklist nouveau

and run dracut -f afterwards, then reboot.

Thanks for your reply ! I would like the problem to be that easy but in fact I already blacklisted nouveau from everywhere as you can see :

[root@wqya0749 ~]# ls /etc/modprobe.d/
blacklist.conf                 blacklist-nouveau.conf.rpmsave  disable-nouveau.conf    lockd.conf  nouveau_blacklist.conf  nouveau-kms.conf                       truescale.conf
blacklist-nouveau.conf.rpmnew  dccp-blacklist.conf             firewalld-sysctls.conf  mlx4.conf   nouveau-blacklist.conf  nvidia-installer-disable-nouveau.conf  tuned.conf

But indeed it looks like for some reasons nouveau is still running …

I still tried to create again the file and ran dracut in case of some miracles but nope. I attached the fresh new logs after this move.
nvidia-bug-report.log (545 KB)

I just noticed that this is a VM with pci passthrough, an important detail. Please see this:
https://www.reddit.com/r/nvidia/comments/5m07h2/pci_passthrough_in_esxi_for_consumer_nvidia_cards/