Problem installing JetPack components after flashing custom kernel build


I have a TX2 module on a custom carrier board which requires USB lane mapping config #5. Also I need some other Jetpack components like CUDA, OpenCV, etc.

I’ve been able to do the proper lane configuration with help from here and there.
However, the installation is missing Jetpack components.

I tried to install the components…

  • …using the sdk manager. I get several errors e.g.:

17:16:59 INFO: Target Deb package [{libnvinfer7 7.1.3-1+cuda10.2}] not installed; [deb_name]: >libnvinfer7_7.1.3-1+cuda10.2_arm64.deb
17:16:59 ERROR: command terminated with error

17:17:01 INFO: Target Deb package [{libnvvpi1 1.0.15}] not installed; [deb_name]: vpi-lib-1.0.15-aarch64-l4t.deb
17:17:01 ERROR: command terminated with error

  • …according to this page chap 1.3.1. However the nvidia-jetpack package does not seem to be available?

  • …separately. I could install the CUDA toolkit, which is also detected by sdk manager as already installed. But I guess I need specific openCV packages. I read somewhere, that nvidia did some optimizations specifically for the platform.

Flashing the OS and installing the other Jetpack components from sdk manager worked fine, however then the USB lane configuration is set to the default.

In general my first two options seemed to be the best, however I don’t know where to find those packages (especially those to resolve the dependency errors in sdk manager). Can someone help me here?



I don’t get your problem here.

Flashing the OS and installing the other Jetpack components from sdk manager worked fine

If flashing OS and installing other jetpack components work fine, then why not just disable the “flashing OS” and let SDK get installed only? So that your OS change will not get overwritten.

If installing them altogether works fine, the separate installation should work too.

That is exactly how I thought it should work. I installed my custom build and tried to install the SDK using the SDK manager. However the installation of the SDK always fails (see above. It reports lots of missing lib (which I can’t find manually using apt)). The installation did only work with my previous installation where the OS was also flashed by the sdk manager.
I’m using latest releases 32.5.1 and Jetpack 4.5.1.

What is your method to “install SDK only”? Do you just remove the click on the “Flash OS” on the sdkm?

Could you share the full sdkm log from your ~/.nvsdkm/logs?

Yes, I do what I assume is standard procedure:

  1. Boot+Connect the board via USB OTG, ensure its detected by sdkm
  2. Select target device (TX2i)
  3. Remove tick from “Flash OS”, accept and hit run

Here are the most recent logs: (28.1 KB)


Just want to know, what is the result on your jetson tx2 when you run command sudo apt-get update?

I’m getting the GPG error tackled in this thread
I’m currently trying to fix it. Unfortunately, however, the jetson sits behind a proxy which might block the url

Ok the problem is resolved now. I found out, that the settings app on the jetson wrote proxy configuration into /etc/apt/apt.conf, which was dysfunctional and shadowed my manual configuration in /etc/apt/apt.conf.d/proxy.conf

similar to this post

Thanks for your time