Problem with bootloader image while updating from Jetpack 5.0.1 to 5.0.2

I am using Jetson Xavier NX and I tried to update Jetpack from 5.0.1 to 5.0.2 following the instructions here : Jetpack 5.0.2 with Jetson Linux 35.1 is now live!. But the last command show me some errors of dependencies

Now, I tried to fix the bootloader and didn’t get any errors after so I reboot. Then now I have a black screen of ubuntu environment. But I can get connected to the Jetson with SSH.

PS: here is the L4T info :

R35 (release), REVISION: 1.0, GCID: 31250864, BOARD: t186ref, EABI: aarch64, DATE: Thu Aug 11 03:40:29 UTC 2022

and the nvidia-jetpack info :

Package: nvidia-jetpack
Version: 5.0.2-b231
Architecture: arm64
Maintainer: NVIDIA Corporation
Installed-Size: 194
Depends: nvidia-jetpack-runtime (= 5.0.2-b231), nvidia-jetpack-dev (= 5.0.2-b231)
Homepage: Autonomous Machines | NVIDIA Developer
Priority: standard
Section: metapackages
Filename: pool/main/n/nvidia-jetpack/nvidia-jetpack_5.0.2-b231_arm64.deb
Size: 29304
SHA256: b1268b2cb969e677163f291967bc7542371a29d536379df3f7dfa1f247ff3fab
SHA1: 7ff288a771b83eec8f80a41ccf0eec490f32e10a
MD5sum: 5cc57807b33630d8edb249e53daf58ed
Description: NVIDIA Jetpack Meta Package
Description-md5: ad1462289bdbc54909ae109d1d32c0a8


Please start by sharing the dmesg and /var/log/xorg.0.log first.

Also, you filed the topic in wrong forum.

Here is dmesg in a file and the /var/log/xorg.0.log
Xorg.0.log (5.9 KB)

log.csv (100.3 KB)

Are you still able to run sudo apt-get upgrade again on your board?

Yes but it doesn’t show any error. Here is the log :

Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages were automatically installed and are no longer required:
cuda-nvprof-11-4 libamd2 libbtf1 libcamd2 libccolamd2 libcholmod3 libcxsparse3 libfreenect-dev libfreenect0.5 libgraphblas3
libklu1 libldl2 libmetis5 libmongoose2 libpython2-dev libpython2.7-dev librbio2 libspqr2 libsuitesparse-dev libumfpack5
python2-dev python2.7-dev ros-noetic-apriltag ros-noetic-apriltag-ros ros-noetic-find-object-2d ros-noetic-libg2o
ros-noetic-libnabo ros-noetic-libpointmatcher ros-noetic-octomap ros-noetic-octomap-msgs
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

PS : I don’t know which forum I should filed my topic

I already moved your topic from TX2 forum to NX forum.

Please reflash the board with sdkmanager. There is no software method to restore it at this moment. You have more than just “blank screen” issue.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.