Problem with flashing Jetson TX1 using Jetpack 2.3

Hello,
I am using Ubuntu 14.04 on my host PC (not VM). And here is the last lines before error of my flashing process log

[   1.8640 ] Sending BCTs
[   1.8655 ] tegrarcm --download bct P2180_A00_LP4_DSC_204Mhz.bct
[   1.8666 ] Applet version 00.01.0000
[   2.0104 ] Sending bct
[   2.0105 ] [................................................] 100%
[   2.1703 ] 
[   2.1704 ] Sending bootloader and pre-requisite binaries
[   2.1716 ] tegrarcm --download ebt cboot.bin 0 0 --download rp1 tegra210-jetson-tx1-p2597-2180-a01-devkit.dtb 0
[   2.1726 ] Applet version 00.01.0000
[   2.3188 ] Sending ebt
[   2.4097 ] 
Error: Return value 1
Command tegrarcm --download ebt cboot.bin 0 0 --download rp1 tegra210-jetson-tx1-p2597-2180-a01-devkit.dtb 0
Failed flashing t210ref.

Any ideas what went wrong?
Thanks in advance.

Is the micro-B USB cable connected? Verify the host sees the Jetson in recovery mode via a response from:

lsusb -d 0955:772
# EDIT: Not sure what happened there but "722" is a typo. JTK1 is 0955:7140, JTX1 is 0955:7721

Note that if you do something with a Jetson in recovery mode (such as flash or clone), then you’ll need to restart in recovery mode for each new recovery mode operation (if you flash once, you need to restart recovery mode to start a new flash attempt…if you clone a partition, then you need to restart recovery mode to start cloning another partition).

Yes, I can see Jetson via lsusb

yury@yury-laptop:~$ lsusb -d 0955:7721
Bus 002 Device 010: ID 0955:7721 NVidia Corp.

I followed the flashing guide showed in a terminal exactly as it was written. I’ve tried several times and always have failed

Did you use JetPack, or did you use the command line “flash.sh” script? You could log the flash.sh output via:

sudo ./flash.sh -S 14580MiB jetson-tx1 mmcblk0p1 2>&1 | tee flash_log.txt

Once it stalls out for a short time you could hit control-c to end the command, then post the flash_log.txt here (post a reply, then mouse hover of the quote icon in the post’s upper right corner…an paper clip attach icon should show up).

I used JetPack. Here is my whole flash log.
https://1drv.ms/u/s!Ag-yO1E4-6Eahp1wqUeRKBDemWHj9Q

It looks like things start out normally and communications with the Jetson works (it isn’t a cable issue and the Jetson is definitely in recovery mode and able to reply).

When it goes to put cboot.bin in, it fails. If you go to the installer directory “Linux_for_Tegra/bootloader”, what is the output of this command:

ls -l `find . -name 'cboot.bin'`
sha1sum `find . -name 'cboot.bin'`

Assuming L4T version R24.2, output should be file sizes 422704 bytes, sha1sum should be “99a8ed5a9292cd1836a09867d79a64596df631ab”. If other than R24.2 (see the “rootfs/etc” subdirectory, “head -n 1 nv_tegra_release”) the values will differ, but can be checked.

yury@yury-laptop:~/Work/NvidiaJetpack/64_TX1/Linux_for_Tegra_64_tx1/bootloader$ ls -l `find . -name 'cboot.bin'`
-rwxr-xr-x 1 root root 422704 Кст  8 20:30 ./cboot.bin
-rwxr-xr-x 1 yury yury 422704 Врс 29 03:58 ./t210ref/cboot.bin
yury@yury-laptop:~/Work/NvidiaJetpack/64_TX1/Linux_for_Tegra_64_tx1/bootloader$ sha1sum `find . -name 'cboot.bin'`
99a8ed5a9292cd1836a09867d79a64596df631ab  ./t210ref/cboot.bin
99a8ed5a9292cd1836a09867d79a64596df631ab  ./cboot.bin
yury@yury-laptop:~/Work/NvidiaJetpack/64_TX1/Linux_for_Tegra_64_tx1/bootloader$

It seems okay

May be the problem can be explained by the source code of tegrarcm. But the error code ‘1’ is too general to find out where exactly the problem is

Given the successful steps for other previous communications with the Jetson, and with the correct content of the file transfer which stalls and fails, I’d recommend wiping the install software directory and re-downloading and unpacking it again (it looks like you did things correctly, and the Jetson seems to start out ok).

Should you want to debug instead, someone will have to give provide information on the meaning of this tegrarcm log excerpt:

[   2.1704 ] Sending bootloader and pre-requisite binaries
[   2.1716 ] tegrarcm --download ebt cboot.bin 0 0 --download rp1 tegra210-jetson-tx1-p2597-2180-a01-devkit.dtb 0
[   2.1726 ] Applet version 00.01.0000
[   2.3188 ] Sending ebt
[   2.4097 ] 
Error: Return value 1
Command tegrarcm --download ebt cboot.bin 0 0 --download rp1 tegra210-jetson-tx1-p2597-2180-a01-devkit.dtb 0
Failed flashing t210ref.

I’ve tried to re-download JetPack again and also downloaded different version (2.2.1), but still got the same result. Except one try when i didn’t get that error and flashing proceeded. But then it hung on message

[   1.1753 ] Sending bootloader and pre-requisite binaries
[   1.1777 ] tegrarcm --download rp1 tegra210-jetson-tx1-p2597-2180-a01-devkit.dtb 0 --download ebt fastboot.bin 0 0
[   1.1798 ] Applet version 00.01.0000
[   1.1944 ] Sending rp1
[   1.1973 ] [................................................] 100%
[   1.4460 ] Sending ebt
[   1.4572 ] [................................................] 100%
[   1.6564 ] 
[   1.6589 ] tegrarcm --boot recovery
[   1.6611 ] Applet version 00.01.0000

And then nothing. But next tries reached only the lines which I showed in log earlier

My observation is that obviously some software and some of the flash data transfer succeeds. I believe your methods are correct, and so issues are either software or hardware. The one time partial increase in how far it gets likely means the eMMC at the location of the previous stall works, although I wouldn’t guarantee 100%…but it has worked at least once. Then it stalled at a different place, not much further ahead. You’ve tried with a clean install and with an alternate version install…I’m thinking it isn’t software either, although there is no smoking gun to prove that.

I’m leaning towards either the USB communications being at fault, or something within the Jetson hardware. USB communications issues are actually somewhat common, although normally associated with the host, especially if the host is a VM. On rare occasion a different non-VM host fixes something like this…or in the case of a VM host, changing USB setup. I don’t know what your situation is so far as ability to try a different host, but provide more details on your current host…Linux version, any USB HUB in the chain of USB cabling, so on. Consider direct attachment of the micro-B USB cable from Jetson direct to host with nothing intervening. Consider using a live CD type Ubuntu which mounts the original hard drive in order to perform the flash if you want to try a different Ubuntu version which does not require permanent install. If you want to try installing with the simplest command line you could try a live CD of something like Fedora 23 (Fedora can’t use JetPack, but you can “sudo ./flash.sh -S 14580MiB jetson-tx1 mmcblk0p1”). You’d be isolating results of how hardware behaves using alternate operating system versions. Use a different micro-B USB cable if available (it usually is not the cable, but most devices these days come with an OTG port, and type micro-B USB cable, so chances are you have a spare somewhere).

It could also be the Jetson. It might be time to RMA, but if it turns out to be a host issue, then you’re back to the same problem. If the issue is something simple like the USB cable or HUB, it’s a big consumption/waste of time for something otherwise quick to fix. So testing the host itself, though requiring time, might be the shortest “predictable” route to go. If you had a second Jetson, then swapping it out for flash test would be instant knowledge of what goes wrong, but RMA and shipping isn’t as fast as testing host issues first.

Thank you for such a detailed answer. I will try to do flash process on different host machine.

Hi , I’m facing exactly the same issues while flashing my TX1 board using Jetpack2.3 from an Ubuntu 14.04 host.
Any luck so far ?

Thanks
Chhavi

Hello,
No, I didn’t manage to revive the board. I tried flashing on a different machine, on different Linux distros (Ubuntu 14.04, Ubuntu 16.05) and with different micro USB cables (and also using different Jetpack versions). The reason why I wanted to flash the board was because the board didn’t boot OS. I didn’t save the logs received via UART. Eventually, I’ve sent the board to our reseller for RMA.

I have same problem and did every suggestion but couldn’t manage to start Jetson TX1 (I have 4 Jetson TX1 and only one of them is not flashing). If there is practical solution please let me know. Otherwise only solution is to use RMA.

Me too, facing the same issue
Already tried many ways, no success!
So, only to use RMA

I’m facing the same problem. I have tried many solutions but it doesn’t work. I’m an amateur, can you explain how to use RMA?

RMA to return a Jetson is listed near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/