Getting error installing Jetpack3.0 for TX2 on ubuntu 14.04

Hi,
I am getting error installing Jetpack3.0 for TX2 on ubuntu 14.04 installed in my laptop. But the same when installed in a Ubuntu 14.04 as a virtual machine, the installation goes through.

Any pointers as to the cause? I am using Dell Latitude 780 and Dell Precision 7710.

Thanks
M


Maybe sharing the errors may help to find out the cause.
As a general rule, using a real x86 ubuntu 14.04 on a linux filesystem is the way to get it working.
Virtual machines usually need to be forced to USB2 mode with increased buffer size.

How do I attach screenshots to this thread?

You can attach to a previous post. There should be an icon with a stapple for that.
You may also post your logs with the code icon </> in a further reply.

While executing the Jetpack 3.0 exe in the Ubuntu 14.04, I reach the screen where we need to select the different packages for installation. I am not able to see any of those packages.

I see the message ‘Downloading update lock’ at the bottom of the screen. It keeps appearing for a while and after that I see an Error.

It basically does not show the different packages for installation of the Jetpack 3.0.

Attached the screenshots. Are you able to see it?

Is the host x86 Ubuntu 14.04 host where you’re running JetPack connected to Internet ?

Later, it may also be required that your Jetson has direct Internet access for downloading packages (through a firewall/proxy requiring authentification may be a problem).

No, it was not connected to the internet. Let me try with that.

It may help…
Be also aware that having your jetson connected to internet with ubuntu and nvidia standard passwords is a security hole.

Hi,
“Virtual machines usually need to be forced to USB2 mode with increased buffer size.”

I am trying to install jetpack 3.0 in Ubuntu 14.04 virtual machine, what buffer size do you recommend for this? Does 150GB suffice? Had there been any issues with installing and flashing Jetson TX2 board from Ubuntu 14.04 vm in the past?

I am also trying to cross compile QT for the Jetson TX2 board as mentioned in the link https://www.innovative-dsp.com/ftp/jetson/Configure%20Cross%20Compiling%20for%20Nvidia%20Jetson%20TX2%20on%20Ubuntu%2064%20bit.pdf

Will more space be required for cross compiling QT? The current space in the board seemed to have become full when trying to build and install packages for enabling QT in the board.

During Jetpack3.0 installation, when we choose the option to “Flash OS image to target”, does it flash a fresh image in to the board? I guess by default, it flashes to the eMMC. Is there a way, we can have the bsp image flashed to the SD Card. We are anticipating addition of packages to the Jetson board which might need more space.

Thanks
M

Buffer sizes are physical RAM. I’m not sure which size is best, but a VM will have some initial starting size. I’m going to guess buffer is in the range of 8KB to a MB (just a guess since I don’t have a VM…but you also don’t want to consume all of the RAM in your system just for a buffer). So far as disk space availability goes you’ll need about 35GB of free space on the host just before you start.

I have no idea what cross compile requirements are for Qt. If you mount a drive (which could be a flash card or USB thumb drive) to somewhere like “/usr/local/” and do all of your build there you won’t hit space limitations of the eMMC. Remember that while flashing a TX2 you can specify a root partition size, and if you don’t, the default is somewhat small (around 14GB I think). For command line flash.sh you could use something like “-S 28GiB”.

Hi,
I have been trying to Flash OS image to the Jetson TX2 board in USB Force Recovery Mode and getting the following error. Any pointers to its cause?

I had excluded ‘Tegra Graphics Debugger’, ‘Vision Works’ and the Documentation on the Host side to fasten up the installation process. Could that be the cause of this issue? Please advise.

:~/Downloads/_installer/logs/64_TX2$ cat flash_os_tx2.log
./tegraflash.py --chip 0x18 --applet “/Downloads/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_prod.bin” --cmd “dump eeprom boardinfo cvm.bin” --skipuid
Welcome to Tegra Flash
version 1.0.0
Type ? or help for help and q or quit to exit
Use ! to execute system commands
 
[   0.0010 ] Generating RCM messages
[   0.0016 ] tegrarcm_v2 --listrcm rcm_list.xml --chip 0x18 --download rcm /Downloads/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_prod.bin 0 0
[   0.0023 ] RCM 0 is saved as rcm_0.rcm
[   0.0046 ] RCM 1 is saved as rcm_1.rcm
[   0.0046 ] List of rcm files are saved in rcm_list.xml
[   0.0046 ]
[   0.0047 ] Signing RCM messages
[   0.0133 ] tegrasign_v2 --key None --list rcm_list.xml --pubkeyhash pub_key.key
[   0.0140 ] Assuming zero filled SBK key
[   0.0300 ]
[   0.0300 ] Copying signature to RCM mesages
[   0.0308 ] tegrarcm_v2 --chip 0x18 --updatesig rcm_list_signed.xml
[   0.0453 ]
[   0.0454 ] Boot Rom communication
[   0.0479 ] tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
[   0.0812 ]
Error: Return value 8
Command tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
Reading board information failed.

Thanks
M

I am trying a guest vm with Ubuntu 14.04 on Windows 10 PC.

On further analysis, I found that the Windows 10 host PC requires a driver(yellow bang showing in Device Manager for NVIDIA APX) for the NVIDIA Jetson TX2 board so that connectivity between the Win 10 host PC and the Ubuntu 14.04 guest vm can be maintained. Screenshots attached.

Any idea, where the Win 10 host drivers for the NVIDIA Jetson TX2 device can be found?

I tried to get online through Windows update, but couldn’t get the driver.

Thanks
M

NVIDIA_JETSON_TX2_drivers_missing_in_Win10_host.PNG

NVIDIA_JETSON_TX2_drivers_missing_in_Win10_host.PNG

I could have this completely wrong (I don’t use VMs), but with a VM Windows itself shouldn’t need a driver…Windows cannot work with a recovery mode Jetson, but the VM is handling it, not Windows. The flash software running within Linux is itself the driver to a recovery mode Jetson (and in fact the package is called the “driver package”…JetPack is a front end to the driver package). I do not know how your VM is configured, but there should be a method of telling Windows this device is to be passed through to the VM as USB (in USB2 mode), and not handled within Windows.

Hi,
You are right. In the configuration I have, I changed and made the Jetson TX2 board as a pass through to the VM in USB 2.0 mode. I selected the Jetson TX2 board from the VM when it showed up as a USB Device in the Ubuntu vm. At that point, the Windows 10 Host PC was showing that device as a Virtual Box device. So, looks like the VM had full control of the Jetson TX2 at that point.

However, I see the same error again.
Something is causing issue in establishing connection between the Ubuntu 14.04 vm and the target Jetson TX2 board. Any pointers? I see a lot of signing logs. Does this have anything to do with signing and keys? If so, How can this issue be resolved?

Also, I have an external SD card which is of higher capacity. Is there a way I can flash the Jetson TX2 OS image to the external SD card instead of the internal eMMC? Please advise.

The error I am seeing with connectivity between the Ubuntu 14.04 vm and the target Jetson TX2 board is below.

[   0.0010 ] Generating RCM messages
[   0.0016 ] tegrarcm_v2 --listrcm rcm_list.xml --chip 0x18 --download rcm /Downloads/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_prod.bin 0 0
[   0.0023 ] RCM 0 is saved as rcm_0.rcm
[   0.0046 ] RCM 1 is saved as rcm_1.rcm
[   0.0046 ] List of rcm files are saved in rcm_list.xml
[   0.0046 ]
[   0.0047 ] Signing RCM messages
[   0.0133 ] tegrasign_v2 --key None --list rcm_list.xml --pubkeyhash pub_key.key
[   0.0140 ] Assuming zero filled SBK key
[   0.0300 ]
[   0.0300 ] Copying signature to RCM mesages
[   0.0308 ] tegrarcm_v2 --chip 0x18 --updatesig rcm_list_signed.xml
[   0.0453 ]
[   0.0454 ] Boot Rom communication
[   0.0479 ] tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
[   0.0812 ]
Error: Return value 8
Command tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
Reading board information failed.

Thanks
M

The signing messages are generally not an issue. The reading of board information failing implies USB failed. This is very very common in a VM. I will suggest that the USB pass-through in USB2 mode was the correct thing to do, but is not sufficient by itself. I do not know what other options may be possible for tweaking USB settings in your VM, but in the past settings for increasing USB buffer size have sometimes solved this issue. Do you have some sort of interface to explore whatever can be tweaked for the VM’s USB options? Can you find something showing current buffer size or buffer options?

One other note…the cable to use with the Jetson in recovery mode is the micro-B USB cable (this is what the cable is which is supplied with the Jetson). There are some cables which are micro-A and won’t work. This too would cause an error.

Hi,
I passed through the previous error by tweaking USB but now stuck in the next step.
It says USB communication failed. Check if device in recovery mode.

The Jetson TX2 was supposed to be in recovery mode. Why is this error coming up? Anything needs to be done after USB Force Reset Recovery and Press Enter for the Jetson TX2 board to be out of the Reset Recovery mode? Please advise.

[ 0.0323 ] Assuming zero filled SBK key
[ 0.0518 ]
[ 0.0519 ] Copying signature to RCM mesages
[ 0.0529 ] tegrarcm_v2 --chip 0x18 --updatesig rcm_list_signed.xml
[ 0.0716 ]
[ 0.0717 ] Boot Rom communication
[ 0.0723 ] tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
[ 0.0728 ] RCM version 0X180001
[ 0.0788 ] Boot Rom communication completed
[ 1.1039 ]
[ 6.1124 ] Retrieving EEPROM data
[ 6.1128 ] tegrarcm_v2 --oem platformdetails eeprom cvm /Downloads/64_TX2/Linux_for_Tegra_tx2/bootloader/cvm.bin
[ 6.1163 ] USB communication failed.Check if device is in recovery
[ 6.1711 ]
[ 6.1769 ] tegradevflash_v2 --oem platformdetails eeprom cvm /Downloads/64_TX2/Linux_for_Tegra_tx2/bootloader/cvm.bin
[ 6.1788 ] Cannot Open USB
[ 6.2109 ]
Error: Return value 8
Command tegradevflash_v2 --oem platformdetails eeprom cvm /home/monisha/Downloads/64_TX2/Linux_for_Tegra_tx2/bootloader/cvm.bin
Reading board information failed.
-VirtualBox:~/Downloads/_installer/logs/64_TX2$

Thanks
M

Are you sure the Jetson is in recovery mode, and that you are using the supplied micro-B USB cable? If so, and going through a HUB, you might try without the HUB. You can verify if the JTX2 is visible in recovery mode via whether this gives a response or not:

lsusb -d 0955:7c18

If you cannot find the Jetson in recovery mode the driver package will not be able to flash. Either the recovery mode is missing, or USB is not visible to the VM.

Also note that for every operation on a Jetson in recovery mode the recovery mode must be restarted before beginning the next operation. For example, you cannot flash twice without re-entering recovery mode between flashes (even if the prior attempt failed and never started).

I have Ubuntu 16.04 LTS installed on host machine (x86-64). Downloaded the Jetpack 3.1 on my host machine which proves i have internet connection. Once i kickstart the JetPack installation, I see the message ‘Downloading update lock’ at the bottom of the screen. It keeps appearing for a while and after that I see an Error. So any pointers ?

I also have the same issue about “downloading update lock”, and I have the internet connection too.