Problem with gcc 4.5.1

Hi,

I have installed CUDA 4.0 on OpenSuse 11.4 having gcc version 4.5.1. When I try to compile SDK using make command the error message is “#error – unsupported GNU version! gcc 4.5 and up are not supported!”. What are the options to solve this problem.

I found two but need suggestions before proceeding.

    Install Intel compiler and try to compile using this but I donot know how to proceed with compilation process and how to change nvcc command to go for Intel Compiler.

    Install gcc 4.4.1 and also do not change gcc 4.5.1 because it is necessary for Suse 11.4 features

I need your suggestions in this regard.

What do you mean by “necessary for Suse 11.4 features”? On Ubuntu, I installed gcc 4.4 packages in addition to the default gcc 4.5. Then I made a directory called /usr/local/gcc44/ and added symlinks in that directory from the unversioned binary names (like gcc, g++, cpp, etc) to the versioned names (gcc-4.4, g+±4.4, cpp-4.4, etc) in /usr/bin. Whenever I want to do CUDA work, I put /usr/local/gcc44 at the beginning of my path. I assume something similar will work for SUSE, but I don’t use that Linux distribution.

Thanks for the reply seibert.

I was trying to install gcc 4.4.1 on Suse 11.4 but unsuccessful. Can you please guide me in this regard as I am new to linux. or provide me link where can I find rpm for gcc 4.4.1

Regards,

Gcc 4.3 works fine with Suse 11.3 in combination with cuda and is also available from the opensuse website for SuSE 11.4. Chances are, this combination will also work well.

Click on the orange ‘get it’ banner on opensuse.org and use the ‘search packages’ to search for ‘gcc43’ for SuSE 11.4.