Problem with installing some packages in l4t-ml container

After starting an interactive session in the container I tried to install tkinter with: pip3 install tk and it seems to be successfully installed:

Collecting tk
  Downloading tk-0.1.0-py3-none-any.whl (3.9 kB)
Installing collected packages: tk
Successfully installed tk-0.1.0

After that, I started a Python3 interpreter and tried to import tkinter using : from tkinter import * but it did not work ModuleNotFoundError: No module named 'tkinter'. However, when I imported it outside the container with the same line of code from tkinter import * it did work since it is a standard Python library. Knowing that I tried to install another libraries like seaborn and they just work fine.


Do you create a python interpreter with 3.8.10, the default version in JetPack 5?
We can import the module without any issue:

$ python3
Python 3.8.10 (default, Nov 14 2022, 12:59:47)
[GCC 9.4.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> from tkinter import *


Hello AastaLLL

Yes I did, I think I missed up with my Jetson by installing and uninstalling many of the libraries and I need to reset it . However I believe that containers are isolated and it should work.


Since the container is an isolated environment, you will need to install the package within the container again.


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.