Problem with using Camera in Python on Jetson Nano 2GB

Hey Guys, I am struggling now for quite some time (2 days to be precise) to get the Camera working in a Python Script.

I need to use OpenCV to detect some Aruco markers so I just set up my Nano yestarday with with the newest Image and used the following script from github to setup OpenCV 4.5 (ended up with Version 4.7) . Camera is connected and can be found via v4l2-ctl ..list-devices
When I’m running the following GStreamer command:

gst-launch-1.0 nvarguscamerasrc sensor_id=0 ! \
 'video/x-raw(memory:NVMM),width=3280, height=2464, framerate=21/1, format=NV12' ! \
 nvvidconv flip-method=2 ! 'video/x-raw, width=816, height=616' ! \
 nvvidconv ! nvegltransform ! nveglglessink -e 

a new window with the capture of the camera is opening and running - just fine.
Now I tried the JacksonHacks CSI-Camera files from their github, but run in some troubles:
When I tried to open those python files via terminal or via Visual Code Studio I always end up with:
Unable to open Camera
I did some research this morning and found some old forum posts from here, where someone suggested to check if GStreamer is activated in OpenCV, so run:


and voila, GStreamer is marked as no. So this should be the problem or am I missing something?

Is there an way to solve this? I’m really new to using Linux and the whole Jetson Nano environment so any help would be nice.

Sorry for the late response, have you managed to get issue resolved or still need the support? Thanks

And you can try this python sample and see if it works:
OpenCV Video Capture with GStreamer doesn't work on ROS-melodic - #3 by DaneLLL

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.