Jetson Nano python script could not open Raspberry Pi V2 Camera

I’m currently trying to use Raspberry Pi V2 Camera connected to Jetson Nano to perform Aruco Marker detection.

I’ve run this code in Jetson Nano and it works fine:
gst-launch-1.0 nvarguscamerasrc sensor_id=0 !
‘video/x-raw(memory:NVMM),width=1920, height=1080, framerate=30/1’ !
nvvidconv flip-method=0 ! ‘video/x-raw,width=960, height=540’ !
nvvidconv ! nvegltransform ! nveglglessink -e

I checked with v4l2-ctl --list-devices and it shows /dev/video0 which means the camera is connected without any issue

But when I try to follow CSI-Camera’s guide to start the camera using python script it shows “Error: Unable to open camera”

Can anyone help?

The script may be lacking a space. Try changing:

 "nvarguscamerasrc sensor-id=%d !"


 "nvarguscamerasrc sensor-id=%d ! "

Modify the frame rate to 30 from 21

I am having the same Issues on a Nano 2GB with Jetpack 4.6.3 (latest).
What Version of OpenCV do you use?

Tried it it shows syntax error

I’m currently using OpenCV Version 3.2.0

I modified it in the python script and it still shows “unable to show camera”

Screenshot from 2023-05-23 16-53-58

Seems not fixed.

I tried it, it still shows Error: Unable to Open Camera

With the same python version as used for this script, try:

import cv2

and check in output for GStreamer SUPPORT. If it shows NO, then it would explains why it fails. In such case, you would install an opencv version with gstreamer enabled.

I see it now, thank you, I’ll install newer version of OpenCv

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.