Raspberry Pi HQ camera with Jetson Nano

Hello everyone,

I am trying to connect the Raspberry Pi HQ camera to the Jetson Nano.

I have configured the pins under jetson-io (both options with IMX477 were tested) and tried to launch a variety of commands like this:
gst-launch-1.0 nvarguscamerasrc sensor-id=0 ! ‘video/x-raw(memory:NVMM),width=1920, height=1080, framerate=30/1, format=NV12’ ! nvvidconv ! ‘video/x-raw(memory:NVMM),format=I420’ ! fpsdisplaysink text-overlay=0 video-sink=fakesink sync=0 -v

Unfortunately I always get an error message like this (No cameras available):

The connection is simple:

Attached you can also find kernel init messages:
klogs.txt (62.4 KB)

I would be very grateful if you could help me to solve the problem. Is the removing of R8 on the camera the only option?

Many thanks in advance

Looks like unable communicate with sensor via i2c. Please remove R8 to try.

[    1.665762] tegra-vii2c 546c0000.i2c: no acknowledge from address 0x1a
[    1.665835] imx477 7-001a: imx477_board_setup: error during i2c read probe (-121)


Hello ShaneCCC,

R8 was removed today. Now it seems to work partly.

Attached you can find klogs and output in terminal for the command mentioned before (camera window doesnt open):
output_camera.txt (7.6 KB)
klogs (1).txt (66.4 KB)

After that i tested CSI code from CSI Module. The command ( ‘gst-launch-1.0 nvarguscamerasrc sensor_id=0 ! nvoverlaysink’) and C++ program worked for me without any problems!!!, but by running python i am getting next error:
andrii@andrii-desktop:~/PythonProjects/CSI-Camera$ python simple_camera.py
nvarguscamerasrc sensor-id=0 ! video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, framerate=(fraction)60/1 ! nvvidconv flip-method=0 ! video/x-raw, width=(int)960, height=(int)540, format=(string)BGRx ! videoconvert ! video/x-raw, format=(string)BGR ! appsink
Error: Unable to open camera

The same happens in my own script:

I tried to use different values for width and height, but nothing worked.

Do you have any ideas what i am doing wrong (of course except of sitting in front of screen :) )?

Do you installed OpenCv?

Yes, i also tried both: opencv-python and opencv-contrib-python. Starting of the CSI_camera.py script in mentioned module throws the next exception:

It looks really strange: everything works when i am starting it from terminal via gst-launch… but the same command is not recognised in python scripts (error messages: unable to open camera or Assertion failed)

Do you know what else i can try?

As info: Python Version 3.8.0, open-cv 4.8.1

Please check if opencv from python has gstreamer support with

import cv2
# Check for gstreamer support from opencv
import re
print('GStreamer support: %s' % re.search(r'GStreamer\:\s+(.*)', cv2.getBuildInformation()).group(1))

Once the python opencv library supports gstreamer backend, it should work with the pipeline from his simple_camera.py script.
His own script pipeline is wrong as it doesn’t feed appsink.
Also you may advise to check if the VideoCapture successfully opened (cam.isOpened()) before trying to use it.

The answer was NO, cam.isOpened() returned False.
I unistalled opencv and followed these steps to install it with GStreamer. Now everything works fine. Thanks a lot!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.