CSI Camera is not working on Jetson nano

I am using CSI-Camera RPi camera V2 with Jetson Nano but the camera is not detected by jetson nano however camera is working fine with raspberry pi.

$ ls /dev/video0
ls: cannot access ‘/dev/video0’: No such file or directory

$ v4l2-ctl --list-devices
Failed to open /dev/video0: No such file or directory

$ gst-launch-1.0 nvarguscamerasrc ! ‘video/x-raw(memory:NVMM),width=3820, height=2464, framerate=21/1, format=NV12’ ! nvvidconv flip-method=0 ! ‘video/x-raw,width=960, height=616’ ! nvvidconv ! nvegltransform ! nveglglessink -e
Setting pipeline to PAUSED …

Using winsys: x11
Pipeline is live and does not need PREROLL …
Got context from element ‘eglglessink0’: gst.egl.EGLDisplay=context, display=(GstEGLDisplay)NULL;
Setting pipeline to PLAYING …
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:521 No cameras available
Got EOS from element “pipeline0”.
Execution ended after 0:00:00.651311176
Setting pipeline to PAUSED …
Setting pipeline to READY …
Setting pipeline to NULL …
Freeing pipeline …

Any help will be appreciated.
Thanks in advance.

hello maaz.bsee55,

may I know the details of your cameras modules.
there are some cameras using the IMX219 that should work with Jetson Nano, please check this github page for reference.

I am using this camera

hello maaz.bsee55,

it’s an infrared camera module, which supports night vision.
since the manufacturer is Waveshare, could you please confirm with them for workable JetPack release version.

Did you try to reverse the FFC connection?

Yes I tried but end up with the same result

VERY sorry to hear that.

and I’ve found this thread: