CSI Camera not found

Hi All,

I am trying to use the Longrunner Raspberry Pi Camera Day & Night Vision on Jetson Nano to run inference over the camera stream.

The camera I am using is:

When searching for “jetson nano” in the “Customer questions & answers” section it is mentioned that “This camera is specifically for the Raspberry Pi board type card with raspbian and or Ubuntu system.”

I am following this guide to setup the camera on Jetson Nano:

When I run the command to test the camera:

$ gst-launch-1.0 nvarguscamerasrc ! nvoverlaysink

I get the following error:

nvbuf_utils: Could not get EGL display connection
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:557 No cameras available
Got EOS from element "pipeline0".
Execution ended after 0:00:00.071803805
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

I tried to put the camera in both the CSI Camera slots and use the sensor_mode attribute to specify the camera. The camera still does not show up.
However, the camera seems to be fine, the left and right sensors are colored in red when the camera is connected to the board.

Are you guys aware of any driver upgrades for the Omnivision OV5647 image sensor or should I just give up and buy a new camera?

Did you integrate the sensor driver to system? Also did you check by v4l2-ctl for the sensor driver function?


I can’t get the camera to show up in /dev/video*.

According to this topic OV5647 sensor is not supported by JetPack out of the box.

To the best of my knowledge, the only working drivers for the OV5647 sensor are Omnivision Linux Drivers | Omnivision OV5647 Linux Driver for Jetson Nano | RidgeRun and Tiny Devices: Jetson Nano - Developing a Pi v1.3 camera driver Part 2 (jas-hacks.blogspot.com).

Yes, default Jetpack didn’t support this sensor. You need to integrate the driver by yourself.