Raspberry Pi Camera v2 not working

Hi everyone!
I’m trying to use a raspberry camera on my jetson, which should be compatible, but I can’t get it to work. I’d appreciate any ideas on things to check to troubleshoot this. Thanks in advance!

{HW}
-nv-jetson-nano-sd-card-image-r32.2.1
-Camera V2 rasp pi 8 megapixel Sony IMX219 image sensor
bought from element 14, its exactly this one:
https://www.element14.com/community/community/raspberry-pi/raspberry-pi-accessories/raspberry-pi-camera-board

{Details}
I followed instructions on the following video
https://www.youtube.com/watch?v=dHvb225Pw1s&feature=emb_logo

In specific, after I connect the camera, the test

gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM),width=3820, height=2464, framerate=21/1, format=NV12' ! nvvidconv flip-method=0 ! 'video/x-raw,width=960, height=616' ! nvvidconv ! nvegltransform ! nveglglessink -e

throws a no cameras connected error:

Setting pipeline to PAUSED ...

Using winsys: x11 
Pipeline is live and does not need PREROLL ...
Got context from element 'eglglessink0': gst.egl.EGLDisplay=context, display=(GstEGLDisplay)NULL;
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:521 No cameras available
Got EOS from element "pipeline0".
Execution ended after 0:00:00.223809135
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

I also tried the example python script on CSI-Camera, indicated in the tutorial
https://www.jetsonhacks.com/2019/04/02/jetson-nano-raspberry-pi-camera/

python simple_camera.py

,which outputs the same rror as befor

nvarguscamerasrc ! video/x-raw(memory:NVMM), width=(int)1280, height=(int)720, format=(string)NV12, framerate=(fraction)60/1 ! nvvidconv flip-method=0 ! video/x-raw, width=(int)1280, height=(int)720, format=(string)BGRx ! videoconvert ! video/x-raw, format=(string)BGR ! appsink
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:521 No cameras available
Gtk-Message: 16:46:10.491: Failed to load module "canberra-gtk-module"

I googled possible errors. Following instructions on the following thread https://devtalk.nvidia.com/default/topic/1052147/jetson-nano/raspberry-pi-camera-v2-1-device-not-detected-error-thrown/, I exported klog.txt

dmesg > klog.txt

I looked it up and found an error in this file
imx219_board_setup error during i2c read probe -121

This error looks the same to this thread
https://devtalk.nvidia.com/default/topic/1068280/jetson-nano/imx219-160-camera-i2c-issues/
, but theres no sulotion for this. Any ideas on what I can check next?

thanks in advance!

You may need to probe the signal to check the power/reset pin is correct driving.

Thanks ShaneCCC! Can you guide me throw on how to do this? I’m a beginner and I’m a little lost.

thanks a lot in advance

I think you need to contact with vendor to make sure this module is compatible with Nano.
The compatible module should working without any extract working for the default system image.

Thanks Shane. I’ll contact them now to make sure, but as far as I know its an official raspberry v2 camera

I had a similar problem with the same product - this answer helped me.

https://devtalk.nvidia.com/default/topic/1050043/jetson-nano/cat-not-get-the-csi-camera-working-erroneous-pipeline-no-element-quot-nvcamerasrc-quot-/

Thanks mkore. I got it working! It was a problem on the 3V voltage pin. I measured the dc voltage on

  • pin1(3v3) and pin6(GND) on J41
    -pin1(GND) and pin15(3v3) the J13

,as indicated in the following thread, and it measured 0.93 V, so its a hardware problem.
https://devtalk.nvidia.com/default/topic/1072065/jetson-nano/raspberry-pi-v2-1-camera-cannot-be-detected/1
and it measured between 1 and 1.3 V. I tried it on a another jetson nano and it worked perfectly!

I willl have to request a refund.