Raspi 2 Camera / no camera available

Hi all, I have seen this issue multiple times in the forum, but found no solution to it.
So, as proposed by the moderator I open a new thread here.

I had a imx219 Raspberry V2.1 camera connected, which worked fine. I added a second, identical camera to the second port, and none of them works since then, even if just one (for sure the one that was working before) is connected.
Also checked connectors and blew them out with air. Connectors checked multiple times. Powersupply is out of the box.

[ 2.008029] i2c /dev entries driver
[ 2.010086] i2c i2c-2: Added multiplexed i2c bus 9
[ 2.010544] i2c i2c-2: Added multiplexed i2c bus 10
[ 2.010550] i2c-mux-gpio cam_i2cmux: 2 port mux on 3180000.i2c adapter
[ 2.011010] imx219 9-0010: tegracam sensor driver:imx219_v2.0.6
[ 2.034477] tegra-i2c 3180000.i2c: no acknowledge from address 0x10
[ 2.034534] imx219 9-0010: imx219_board_setup: error during i2c read probe (-121)
[ 2.034603] imx219 9-0010: board setup failed
[ 2.034735] imx219: probe of 9-0010 failed with error -121

I re-imaged the SD sure for 20 times with no success. Camera works fine on a Raspi, thus camera doesn’t seem to be the issue.
There is no dev/video1 or 2 device.
Hope that anyone can help me :-) Thanks a lot in advance

hello felix15,

I assume you’re using TX2 NX, right?
could you please let us know which JetPack release you’re working with, thanks

Hi Jerry, it’s a Jetson Nano 4GB B0 with newest image from yesterday. The image contains JetPack 4.6

Uups, just saw, I am in the wrong device chat… sorry guys.

moving this topic to Nano series.

hello felix15,

Jetson Nano is by default support Raspberry v2. could you please confirm this v2.1 is identical with v2 series?

Yes, and the module was working. Until I connected a second module

hello felix15,

could you please confirm the pin direction,
please also confirm both cam-1 and cam-2 camera connector are also functional.

Cable is plugged in the right way. Blue ribbon cable side points to the outside of board. Ribbon cable contacts towards processor. Electrical contacts of connector are also in board direction.
Thus, cable definitely plugged in correctly.
Connector slots are mechanically fine. Cleaned with slight air pressure and checked with a lense. No bent contacts. No visible welding failures seen. Ribbon cable contacts fine too.


  1. to connect those RPi cameras to other devices, RP or Jetson Nano
  2. to connect a RPi Camera v2 on cam0 and cam1 each other

Hi MtHiker, that is exactly what I already did, except to connect it to another Jetson board, as I only have one. Plus, as said, the camera was working on the board. The cam works just fine on the Rpi

Just received 2 brand new camera modules. Both from serious provider. Not any junk.
Tried both camera modules separate from each other. Plugged in BEFORE powering on. Both don’t work. Both work on my RPi.

DMESG shows:
[ 1.334816] i2c i2c-6: Added multiplexed i2c bus 7
[ 1.335189] i2c i2c-6: Added multiplexed i2c bus 8
[ 1.335194] i2c-mux-gpio cam_i2cmux: 2 port mux on Tegra I2C adapter adapter
[ 1.335825] imx219 7-0010: tegracam sensor driver:imx219_v2.0.6
[ 1.361081] imx219 8-0010: tegracam sensor driver:imx219_v2.0.6
[ 1.362468] tegradc tegradc.0: unblank
[ 1.375577] tegradc tegradc.0: nominal-pclk:138500000 parent:138500000 div:1.0 pclk:138500000 137115000~150965000
[ 1.375665] tegradc tegradc.0: hdmi: tmds rate:138500K prod-setting:prod_c_hdmi_75m_150m
[ 1.376725] tegradc tegradc.0: hdmi: get YCC quant from EDID.
[ 1.384364] tegra-vii2c 546c0000.i2c: no acknowledge from address 0x10
[ 1.384447] imx219 8-0010: imx219_board_setup: error during i2c read probe (-121)
[ 1.384571] imx219 8-0010: board setup failed
[ 1.384646] imx219: probe of 8-0010 failed with error -121

Brand new v2.1 RPi cameras .
None of them works at Jetson Nano developer kit.
BTW, did you flash SD card through SDK manager?

hello felix15,

it’s i2c no ack failure, it usually caused by regulator settings.
how did you flash Nano platform, did you using SDKManager to flash with the native JetPack image?

Thanks Jerry for this great news :-)
No, I flashed with the actual image available, which contains JP4.6, but also tried with an older version containing JP4.4. The reason is quite simple…I have no dedicated Ubuntu machine available and was under the assumption that the current image supports the sensor.
So, what you are saying is, that I have to flash the board with SDKManager ? Is there a dedicated/special setting I need to be aware of, to set the correct regulator settings ?

please access NVIDIA SDK Manager | NVIDIA Developer to setup your development environment for image flashing.

Thanks Jerry, but I am still curious about the difference between the precompiled image and the one I create with SDKManager. Or asked is other words: Which setting/option within the SDK manager ensures that the regulator settings will be corrected ?

hello felix15,

because Jetson Nano is by default support Raspberry v2, IMX219 camera sensor.
would like to ask you to use the native JetPack release to narrow down the issue.

OK, any specific version ?
Will take some days, as I need to get to a Linux host first

hello felix15,

Jetson Nano support Raspberry v2, imx219 at the very beginning,
however, you could install the latest JetPack-4.6 release for confirmation.