Nano not recognizing IMX219 camera

Hi, I am using a V2 Raspberry Pi IMX219 camera on my Jetson Nano, and it does not recognize the camera. When I run the command “gst-launch-1.0 nvarguscamerasrc ! nvoverlaysink”, it puts out the error message I have attached, saying “557 No cameras available”. When I try to find dev/video0 in my filesystem, it is not there. This camera should be able to work out of the box with no drivers, and it has a ribbon connector rather than a USB. Can anyone point me in the right direction as to how to fix this? Thanks.

IF you use Jetson Nano Devkit, I recommend, you’d make sure FFC is installed with correct side.
As you said, RPi V2 camera should be detected and shown /dev/video0, then run without any effort.

I’ve made sure that the FFC is installed facing the correct side, and that it is properly locked into place. I am using Jetson Nano devkit, yes. It should be detected and showing in /dev/video0, but it isn’t. Any other tips on what might be going on to cause that?

I would do

  • find some related kernel errors
  • find another RPi V2 camera and replace it
  • find another Jetson Nano devkit or RPi, and install the camera to test

I’ve already done the second one - this is actually the second camera I’m testing for it, the first one displayed the exact same error. I’d rather not have to buy a whole new board, but will do that if I have to. Can you elaborate a bit on related kernel errors? I’m not sure quite what you mean by that. Thanks for the response, by the way!

hello Seaweedhorse,

there’s sensor probing during kernel initialization stage, please gather kernel messages for reference,
for example, $ dmesg > klog.txt

Ok, I ran dmesg, and it produced the following klog.txt. What should I be looking for in it? The only line that looks relevant to me is “tegra_camera_platform tegra-camera-platform: tegra_camera_probe:camera_platform_driver probe”.

klog.txt (67.4 KB)

hello Seaweedhorse,

there’re failures to probe your imx219, i2c no acknowledge errors usually related to regulator settings.
for example,

[    1.693363] i2c-mux-gpio cam_i2cmux: 2 port mux on Tegra I2C adapter adapter
[    1.694089] imx219 7-0010: tegracam sensor driver:imx219_v2.0.6
[    1.717426] tegra-vii2c 546c0000.i2c: no acknowledge from address 0x10
[    1.717523] imx219 7-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.725095] imx219 7-0010: board setup failed
[    1.729582] imx219: probe of 7-0010 failed with error -121
[    1.730081] imx219 8-0010: tegracam sensor driver:imx219_v2.0.6
[    1.753360] tegra-vii2c 546c0000.i2c: no acknowledge from address 0x10
[    1.753451] imx219 8-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.760986] imx219 8-0010: board setup failed
[    1.765419] imx219: probe of 8-0010 failed with error -121

may I know which sensor vendor you’d contact with for buying.
please ask them to confirm the workable JetPack release version.

Do you have clean L4T image on your devkit?

JerryChang: Good to know. Might the board setup errors be an issue with the board itself, rather than the camera? As I said, I have tried two cameras now, both of which should be able to work out of the box on Jetson Nano, to no success. The one I am currently trying is made by Raspberry Pi; I can’t find any documentation online for what JetPack release version it is compatible with. This is the link:

and here is the link for the first camera I tried, that also doesn’t work:

MtHiker, I downloaded the current SD card image from the getting started guide. I thought this had JetPack and all necessary basic things like the Linux system. It seems L4T is included in JetPack, and I’m pretty sure JetPack is included in the SD card image from Nvidia, so I think I do have a clean L4T image, but I may be wrong.

As an update/solution: I am now able to use the camera. I followed the advice in the thread linked below; it turns out the camera needed to be connected before the board started up, and I was starting the board up first, then connecting the camera. That thread with the solution hadn’t come up in a google search presumably because it included the dmesg log results, which I hadn’t run and wasn’t searching for at first. Leaving this here in case anyone else encounters the same issue again.