LI IMX219 MIPI No Camera Found on Jetson Nano

Hello all,
I’m trying to use my IMX219 camera from Leopard Imaging, which should be supported out of the box on my jetson nano. However, it does not show up and whenever i try to run nvgstcapture-1.0 I recieve the following:
===== NVMEDIA: NVENC =====
NvMMLiteBlockCreate : Block : BlockType = 4
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:645 No cameras available

(nvgstcapture-1.0:9248): GStreamer-CRITICAL **: 02:33:47.189: gst_mini_object_set_qdata: assertion ‘object != NULL’ failed

I have jetpack 4.5 installed. Any help to use the camera?

Did you integrate the driver from Leopard?
what the v4l2-ctl --list-devices shows?

Could you provide a source on how to do so? I have the zip file for the drivers but not sure how to do it, as I thought it is natively supported on the nano.

When using v4l2-ctl --list-devices shows the following:

Failed to open /dev/video0: No such file or directory

@SimonZhu
Could you provide step to integrate LI’s driver to Nano.

Thanks

@user37924 The Nano Devkit includes 2 camera interfaces. Only one works. Please try another one to see if it works. The original driver should support IMX219 module directly.

@SimonZhu @ShaneCCC I tried both slots and the camera did not work. I tried flashing different jetpacks, i.e., 4.2, 4.3, 4.5 and 4.6 and non of them worked on either slot. Also, I tried flashing with SDK Manager, and still nothing. Any help?

Check if can get any clue by below command.

dmesg | grep -i imx219

@ShaneCCC I get the following:

The log tell your connection or HW have problem to communicate with sensor via i2c.

So, should I test a different module to see if it’s a camera issue, or what do you suggest?

If you have different module you can do the cross-validation.

@SimonZhu
Any comment for this case?

Thanks

@user37924
Could you take a picture about the whole camera kit? We would like to check the connections.
We confirmed that this module can work on Nano Devkit. If it still doesn’t work, we may need to check to see if the issue is caused by the hardware.

@ShaneCCC , @SimonZhu I used a RPi Camera v2 and it worked out of the box. I’m guessing this is a hardware issue related to the module I got?

@user37924
If the RPi camera module works well, the issue is most likely caused by the IMX219 camera module. You may need to contact support@leopardimaging.com for RMA.

I’m facing similar problem, but in my case the camera port-0 is not working but camera port-1 working fine. two cameras were working earlier. But due to a crash I re flashed the sd card and now one camera is not wrking. similarly the board will shutdown abruptly.
board used: Jetson nano B01

  1. I have two cameras (sony IMX219 sensors).

  2. Both Camera modules are working in port-1

  3. I also checked the connection (Ribbon cables) and could not observe any connection issue.

  4. I got below output .when i executed the command “dmesg | grep -i imx219”
    image

  5. Also got low error message when tried to run the camera with the command “nvgstcapture-1.0 --camsrc=0”
    Encoder null, cannot set bitrate!
    Encoder Profile = High
    Runtime USB Camera Commands:

Help : ‘h’
Quit : ‘q’
Set Capture Mode:
mo:
(1): image
(2): video
Get Capture Mode:
gmo
Capture: enter ‘j’ OR
followed by a timer (e.g., jx5000, capture after 5 seconds) OR
followed by multishot count (e.g., j:6, capture 6 images)
timer/multihot values are optional, capture defaults to single shot with timer=0s
Start Recording : enter ‘1’
Stop Recording : enter ‘0’
Set Preview Resolution:
pcr: e.g., pcr:2
(0) : 176x144
(1) : 320x240
(2) : 640x480
(3) : 1280x720
(4) : 1920x1080
NOTE: Preview/Encode resolution will be same as Capture resolution for USB-Camera
Get Preview Resolution:
gpcr
Get Image Capture Resolution:
gicr
Get Video Capture Resolution:
gvcr
Set Capture Device Node:
cdn: e.g., cdn:0
(0): /dev/video0
(1): /dev/video1
(2): /dev/video2
Get Capture Device Node:
gcdn

Runtime encoder configuration options:

Set Encoding Bit-rate(in bytes):
br: e.g., br:4000000
Get Encoding Bit-rate(in bytes):
gbr
Set Encoding Profile(only for H.264):
ep: e.g., ep:1
(0): Baseline
(1): Main
(2): High
Get Encoding Profile(only for H.264):
gep
Force IDR Frame on video Encoder(only for H.264):
Enter ‘f’

** Message: 18:23:08.894: main:4670 iterating capture loop …
ERROR on bus: by /GstPipeline:capture_native_pipeline/GstBin:cap_bin/GstV4l2Src:v4l2src0: Internal data stream error.
debug info:
gstbasesrc.c(3055): gst_base_src_loop (): /GstPipeline:capture_native_pipeline/GstBin:cap_bin/GstV4l2Src:v4l2src0:
streaming stopped, reason not-negotiated (-4)
** Message: 18:23:09.000: main:4680 Capture completed
** Message: 18:23:09.009: main:4729 Camera application will now exit

  1. Later I tried below steps based the thread: probing issue
  2. disconnected power jack
  3. Reconnected the camera
  4. Rebooted the board
    Still no luck

The parameter “–camsrc=0” is for USB camera you should using --sensor-id for different sensor.

Thank you so much, it resolved my issue. With–camerasrc=1 argument one of the CSI camera worked, And --camerasrc=0 was not working too. This lead me to the confusion.