Not able to use csi camera by IMX219-77IR Camera

when i run this command according to waveshare website :-
DISPLAY=:0.0 nvgstcapture-1.0

nothing is happening
Encoder null, cannot set bitrate!
Encoder Profile = High
Supported resolutions in case of ARGUS Camera
(2) : 640x480
(3) : 1280x720
(4) : 1920x1080
(5) : 2104x1560
(6) : 2592x1944
(7) : 2616x1472
(8) : 3840x2160
(9) : 3896x2192
(10): 4208x3120
(11): 5632x3168
(12): 5632x4224

Runtime ARGUS Camera Commands:

Help : ‘h’
Quit : ‘q’
Set Capture Mode:
(1): image
(2): video
Get Capture Mode:
Set sensor orientation:
(0): none
(1): Rotate counter-clockwise 90 degrees
(2): Rotate 180 degrees
(3): Rotate clockwise 90 degrees
Get sensor orientation:
Set sensor mode:
smo: e.g., smo:1
Get sensor mode:
Set Whitebalance Mode:
(0): off
(1): auto
(2): incandescent
(3): fluorescent
(4): warm-fluorescent
(5): daylight
(6): cloudy-daylight
(7): twilight
(8): shade
(9): manual
Get Whitebalance Mode:
Set Saturation (0 to 2):
st: e.g., st:1.25
Get Saturation:
Set Exposure Compensation (-2 to 2):
ec: e.g., ec:-2
Get Exposure Compensation:
Set Auto Whitebalance Lock:
awbl: e.g., awbl:0
Get Auto Whitebalance Lock:
Set Auto Exposure Lock:
ael: e.g., ael:0
Get Auto Exposure Lock:
Set TNR Mode:
tnrm: e.g., tnrm:1
(0): OFF
(1): FAST
Get TNR Mode:
Set TNR Strength (-1 to 1):
tnrs: e.g., tnrs:0.5
Get TNR Strength:
Set EE Mode:
eem: e.g., eem:1
(0): OFF
(1): FAST
Get EE Mode:
Set EE Strength (-1 to 1):
ees: e.g., ees:0.5
Get EE Strength:
Set Auto Exposure Anti-Banding (0 to 3):
aeab: e.g., aeab:2
(0): OFF
(2): MODE 50HZ
(3): MODE 60HZ
Get Auto Exposure Anti-Banding:
Set Gain Range:
gr: e.g., gr:1 16
Get Gain Range:
Set Exposure Time Range:
etr: e.g., etr:34000 35000
Get Exposure Time Range:
Set ISP Digital Gain Range:
dgr: e.g., dgr:2 152
Get ISP Digital Gain Range:
Capture: enter ‘j’ OR
followed by a timer (e.g., jx5000, capture after 5 seconds) OR
followed by multishot count (e.g., j:6, capture 6 images)
timer/multihot values are optional, capture defaults to single shot with timer=0s
Start Recording : enter ‘1’
Stop Recording : enter ‘0’
Video snapshot : enter ‘2’ (While recording video)
Get Preview Resolution:
Get Image Capture Resolution:
Get Video Capture Resolution:

Runtime encoder configuration options:

Set Encoding Bit-rate(in bytes):
br: e.g., br:4000000
Get Encoding Bit-rate(in bytes):
Set Encoding Profile(only for H.264):
ep: e.g., ep:1
(0): Baseline
(1): Main
(2): High
Get Encoding Profile(only for H.264):
Force IDR Frame on video Encoder(only for H.264):
Enter ‘f’

(Argus) Error Timeout: (propagating from src/rpc/socket/client/SocketClientDispatch.cpp, function openSocketConnection(), line 219)
(Argus) Error Timeout: Cannot create camera provider (in src/rpc/socket/client/SocketClientDispatch.cpp, function createCameraProvider(), line 106)
bitrate = 4000000
Encoder Profile = High
Encoder control-rate = 1
Encoder EnableTwopassCBR = 0

Using winsys: x11
** Message: 01:14:59.235: main:4648 iterating capture loop …
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:735 Failed to create CameraProvider
NvMMLiteOpen : Block : BlockType = 4
===== NVMEDIA: NVENC =====
NvMMLiteBlockCreate : Block : BlockType = 4

this is the msg i got

a piece of desktop is being captured

Previously I got the report 740 : no camera available then I configured the csi connector using overly to imx 219 dual then the above thing happened.


Is this on a Jetson device by chance?

It is a seeed studio recomputer j1010 4gb

What NVIDIA hardware is being used? Knowing this helps me find the best forum category for your issue.


Jetson nano 4 gb.

Thanks. I will move this topic to the Jetson Nano category.

Did you enable imx219 by jetson-io?

  1. Check if imx219 driver was loaded. v4l2-ctl --all
  2. Streaming by v4l2-ctl to confirm the HW.

ssvps@ssvps-desktop:~$ v412-ctl --all

Failed to open /dev/video0: No such file or directory

It is showing this.

After I run v4l2-ctl it shows all the options.

Also the camera I am using is imx 219 by waveshare where on their website it is mentioned that it is only made for jetson nano .
Here is the link:-

The sensor driver load failed.
Did you enable the imx219 by jetson-io?

Yeah csi config is set to imx219 dual, I also tried to set it as imx 219 - b but it did not worked. How to load driver manually?

Check the kernel message by below command.

dmesg | grep -i imx219

Ssvps@ssvps-desktop:~$ dmesg | grep -t imx219

[ 1.328488] tmx219 7-0010: tegracam sensor driver: tmx219_v2.0.6

[ 1.351869] tmx219 7-0010: tmx219_board_setup: error during 12c read probe (- 121)

[ 1.351936] imx219 7-0010: board setup failed

[ 1.351990] imx219: probe of 7-0010 failed with error ¹-121 1.352413] inx219 8-0010: tegracam sensor driver:imx219_v2.0.6



1.375760] imx219 8-0010: imx219_board_setup: error during 12c read probe (-


1.375820] imx219 8-0010: board setup failed

I 1.375870] imx219: probe of 8-0010 failed with error -121

This is the following message I got.

Looks like unable to communicate with sensor via I2C command that could be HW or connection issue.

So what am I supposed to do now? And does that mean drivers are loaded correctly and it’s definitely not an software/kernal issue?

Right, need to check the connection or HW.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.