Connecting Rapberrry pi HQ camera module with Jetson Nano

I have raspberry pi 2018 HQ camera module v1.0 IMX 477 and jetson nano B01 I cannot understand the ridgesrun forum because this is my first time using Linux (I tried it but its for only till 4.5 jetpack). Some of topics show I have to remove r8 sensor others show I can directly install it via driver. I am using jetpack 4.6.1 and open cv 4.5.1 with CUDA. Can anyone please guide me through each step which I have to follow to get the camera working with my jetson.
Any help or direction would be appreciated .

  1. Remove the R8 resistor.
  2. use jetson-io to enable imx477
  3. save and reboot
  4. check if imx477 is loading correctly by “dmesg | grep -i imx477”
  5. Confirm by v4l2-ctl.
v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --set-ctrl bypass_mode=0 --stream-mmap

Hey, I have tried this and now the camera is working but I am not able to see any sort of dispay when i write the commands like

  1. v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --set-ctrl bypass_mode=0 --stream-mmap

  2. nvgstcapture-1.0 --orientation=2

  3. gst-launch-1.0 nvarguscamerasrc sensor_id=0 ! nvoverlaysink

Please check this command.

gst-launch-1.0 nvarguscamerasrc sensor-id=0 ! 'video/x-raw(memory:NVMM),width=1920,height=1080,framerate=30/1,format=NV12' ! nvvidconv ! fpsdisplaysink video-sink=xvimagesink sync=false -v

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.