Connecting Raspberry Pi HQ IMX477 with Jetson Nano

I have an Nvidia Jetson Nano B01 Developer Kit running Jetpack 4.4 and I am having difficulty trying to connect a raspberryPi HQ IMX477 sensor to it. What is the most stable/up to date way to do this? I am not able to connect the nano to the internet, so any package installations or updates would have be done manually or via file transfer.

I first attempted connecting using the drivers from Arducam following this video (Using Rpi HQ Camera w/ Jetson Xavier NX & Nano (IMX477 Module, Up to 4k@30FPS) - YouTube), which at least got the nano to recognize the camera, however the script would hang and no video stream would come up. For this approach I did remove the R8 resistor. I chose Jetpack 4.4 because that is the one that provided a kernel that was compatible with the driver from the link.

I also attempted a fresh OS flash and trying to install the drivers from ridge run, but for some reason when I run the apt-get install --reinstall on the .deb files, I get errors: "“problem with mergelist” “the package lists or status file could not be parsed or opened”. I am not sure what is causing this as it was a fresh OS, and the kernal versions in the driver name match what I have on the OS. I have not had issues installing other deb files like those for software packages. For this I was also using a camera with a removed R8 resistor.

I then saw a couple threads saying that the camera should be supported simply by doing some jetson-io command? Is that true? Do I still need to remove the R8 resistor or can I use a default raspberry pi hq camera?

The forum will only allow me to share one link, so I can’t link to all the sources/forums I mentioned.

I have been having a lot of trouble with this so any help would be greatly appreciated!

hello alecy14,

we’ve tested on JP-4.6.3/l4t-r32.7.3, it’s confirmed IMX477 works normally on Jetson Nano platforms.
is it possible for moving to JetPack 4.6.3 for confirmation?

Hello Jerry,

Thank you for the reply. Yes I can use that version of Jetpack. Is there a set up step by step instructions/example on how to enable compatibility with the raspberry pi HQ camera with your suggested version of jetpack (for example, what commands I need to run)? And should I test with or without the R8 resistor removed on the camera board? Thanks.

Edit: is there an SD card image method for 4.6.3? I actually don’t currently have a method of installing via the SDK manager. I only see 4.6.1 has an SD card image method.

hello alecy14,

you may perform OTA update for moving to new release version.
please see-also Solution : dpkg: error processing package nvidia-l4t-bootloader --configure)

BTW, we’re testing IMX477 without the R8 resistor.

Hey Jerry,

Unfortunately I am operating offline and unable to connect the jetson nano to the internet, and I don’t have an ubuntu host machine (only a windows machine). Is there another way to get 4.6.3 installed?

Also I do have a backup camera with the R8 resistor in tact if that is what you recommend.

hello alecy14,

let’s narrow down the issue.
back to your current setup, Jetpack-4.4
may I know what’s the failure reported from the kernel side? $ dmesg > klogs.txt
is it able to access the camera stream by Applications Using V4L2 IOCTL Directly.


For the logs I will have to check tomorrow morning as I am not currently with the device.

I will also attempt to use the V4L2 IOCTL tomorrow, but I expect without the driver being able to be installed, it won’t be able to read the camera.

The error with installing the *.deb files occured with the drivers provided by ridge run.

I was able to install the arducam driver file on JP 4.4 and it seemed to recognize the camera, but couldn’t produce a feed. I can try that configuration with the V4L2 IOCTL and let you know how it goes.

In the mean time, is providing a 4.6.3 sd card image not possible?


hello alecy14,

there’s no 4.6.3 sd card image, please upgrade that by OTA approach,
furthermore, please also contact with the vendor for solving the installation failures.

The last thing the klog.txt says is “USB Mass Storage device detected” from where I copied the two *.deb files from RidgeRun.

When I run sudo apt-get install --reinstall ./nvidia-l4t-kernel_4.9.140-tegra-32.4.3-20200625213407_arm64.deb on Jetpack 4.4, I simply get:

Reading package lists… Error!
E: Sub-process Popen returned an error code (2)
E: Encountered a section with no Package: header
E: Problem with MergeList /home/username/Documents/nvidia-l4t-kernel_4.9.140-tegra-32.4.3-20200625213407_arm64.deb
E: The package lists or status file could not be parsed or opened.

This is the first action i did after a fresh OS flash. The drivers have been confirmed to work with Jetpack 4.4, so not sure why it can’t even read them: Raspberry Pi HQ camera IMX477 Driver | Linux driver for Jetson | RidgeRun - RidgeRun Developer Connection


I was able to flash 4.6.1 to a microSD and perform an OTA update and now running L4T 32.7.3.

What are the next steps to detect/use the camera in the terminal?


hello alecy14,

it’s Jetson-IO utility to update the CSI configuration.
please see-also developer guide, Running Jetson-IO. please check whether you’re able to Configuring the CSI Connector.

Thanks Jerry!

I was able to get the camera running after using the Jetson-IO tool on Jetpack 4.6.1 (with an OTA update to L4T 32.7.3). No third party drivers needed! The camera does have the R8 resistor removed, but may or may not work with the stock camera as well. Also interested to see if it will work with the stock 4.6.1 jetpack OS without any updates.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.