Raspberry Pi Camera V3 Module and V1 not supported?

I am trying to connect 2 cameras to the jetson nano dev kit, i have 2 cameras, a Raspberry Cam V1 and V3, and i get /dev/video0 not found. I have the Ubuntu 18.04 on it, used SDK with Jetpack 4.

Read somewhere that i might need to configure the CSI connector, not sure how easy that would be.

Any help?

PS: the V1 camera was already tested on Raspberry pi to check if it works and both were purchased this year (2023).


hello christopher50,

may I know which JP-4 version you’re working with? is it the latest release version, JetPack 4.6.4 / l4t-r32.7.4 ?

Hi. Thanks for the reply.
Yes it is the latest version. It was installed 1/2 weeks ago. I noticed that all the hardware modifications needed is to remove the R8 resistor on the camera.
Is that still the solution or there are other methods that dont require modifications or new equipment?

For got to mention that the V1 camera is the HQ V1. Then i was referring to the R8 resistor it was related with the HQ. But if there is another way to use the V3, would be great :)

this is the supported camera module, please enable it via Jetson-IO.

Update: I managed to put the camera working by removing the R8 resistor and change the CSI to 477.
But only one device is being detected, video0. Both cameras work in the same camera 0 slot, but video1 does not appears.
when i run the camera sensor id = 1 also cannot detect or open the camera. And also checked the connection like 5 times. Not sure whats the problem now

hello christopher50,

please share kernel init logs for checking device registration status. i.e. $ dmesg > klogs.txt

klogs.txt (58.4 KB)

Here are the klogs

hello christopher50,

it looks a probing failure has reported by IMX219.

[    1.638499] imx219 8-0010: tegracam sensor driver:imx219_v2.0.6
[    1.661777] tegra-vii2c 546c0000.i2c: no acknowledge from address 0x10
[    1.661853] imx219 8-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.669492] imx219 8-0010: board setup failed
[    1.673954] imx219: probe of 8-0010 failed with error -121

had you execute Jetson-IO to configure the CSI connections? could you please share your steps for reference.

1- remove R8 resistor from Raspberry camera HQ
2-configure CSI with “sudo /opt/nvidia/jetson-io/jetson-io.py”
3-Since the HQ has IMX477, i selected IMX477 dual
4- Reboot
5- connect cameras
6- camera slot 0 worked with both cameras :)
7- camera slot 1 does not work :(

hello christopher50,

but your hardware device are… IMX219 + IMX477, right?
IIRC, there’s CSI configuration for such combination, could you please re-configure the system for confirmation.

the raspberry pi page says the HQ camera has IMX477 – " Raspberry Pi High Quality Camera, 12.3MP IMX477 Sensor".

i have given up on the other camera. Now i am using 2 HQ cameras, therefor i selected the IMX477 dual

hello christopher50,

we’ve tested and confirm it’s working on Jetson Nano/r32.7.3 with IMX477’s R8 resistor removed.

i understand but the 2nd camera port is not working, and the jetson nano was built last month so i assume it has the latest version

hello christopher50,

please double check release tag, i.e. $ cat /etc/nv_tegra_release for confirmation.

R32 (release), REVISION: 7.4, GCID: 33514132, BOARD: t210ref, EABI: aarch64, DATE: Fri Jun 9 04:25:08 UTC 2023

hello christopher50,

it should detect IMX477 for the two camera slots as you select IMX477 dual dtbo file,
could you please share the kernel message again for checking,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.