Connect Raspberry Pi HQ Camera Jetson Nano Developer Kit

Jetson info:
NVIDIA NVIDIA Jetson Nano Developer Kit 4GB
L4T 32.7.3 [ JetPack 4.6.3 ]
Ubuntu 18.04.6 LTS
Kernel Version: 4.9.299-tegra


I have been working to connect the Raspberry Pi HQ Camera to the Jetson Nano Developer kit.
I am far from the first one to tackle this issue as seen here Raspberry Pi HQ camera IMX477 - #7 by
and here

Both seem to be using JetPack version 4.6.3.
Using the SDK manager I am able to flash 4.6.3 onto an SD card.

I then run:

sudo /opt/nvidia/jetson-io/

I select the Dual IMX477 config and reboot the Jetson Nano.

Then when I do

ls /dev/vid*

I get:

ls cannot access 'dev/vid*': No such file or directory

Wheras I should see


When I do

jetson463@ubuntu:~$ dmesg | grep imx477
[    1.858316] imx477 7-001a: tegracam sensor driver:imx477_v2.0.6
[    2.158747] imx477 7-001a: imx477_board_setup: error during i2c read probe (-121)
[    2.166316] imx477 7-001a: board setup failed
[    2.170845] imx477: probe of 7-001a failed with error -121
[    2.171429] imx477 8-001a: tegracam sensor driver:imx477_v2.0.6
[    2.471825] imx477 8-001a: imx477_board_setup: error during i2c read probe (-121)
[    2.479351] imx477 8-001a: board setup failed
[    2.483817] imx477: probe of 8-001a failed with error -121

I have double checked my CSI connections, tried multiple HQ cameras. Tried a different Jetson Nano board, and was even able to test out other cameras such as IMX219 raspberry pi cameras which did work.
I have also tried 4.6.4 with similar results, and was unable to get any of RidgeRun’s drivers working with older JetPack versions.

For some reason I am unable to get the HQ camera working. Any help that could be provided would be greatly appreciated.

let me moving this topic to Jetson Nano category for better issue triage.

we’ve tested on JP-4.6.3/l4t-r32.7.3, it’s confirmed IMX477 works normally on Jetson Nano platforms.
but… we’re testing IMX477 without the R8 resistor.

please see-also this page, Compatibility with NVIDIA®Jetson™ Platforms.

Hi Jerry,

I am attempting this with the Raspberry Pi HQ Cameras V 1.0 with the R8 resistor intact. I am initially attempting this without utilizing RidgeRun’s Drivers.

Let me know if you need any system info for trouble-shooting purposes.


I was able to eventually get the Raspberry Pi HQ camera working with the Jetson Nano (Developer Kit). However, I was only able to get the RPi HQ cam working by removing the R8 resistor, and then utilizing JP-4.6.3/l4r-r32.7.3. I have done multiple tests and have been unable to get the RPi HQ to work without removing the resistor. Any explanation as to why this might be would be greatly appreciated.

My test conditions were utilizing the Jetson Nano Developer Kit Model rev B01 (PN: 945-13450-0000-100). I used the Nvidia SDK manager on an Ubuntu 18.04 host machine to Flash and install dependencies.

the reason for removing the R8 resistor is described in the page.
re-cap as following…

Compatibility with NVIDIA®Jetson™ Platforms

The Raspberry Pi HQ camera module requires a hardware modification in order to work with Jetson Platforms. Jetson Platforms provide 1.8V for reset GPIO in the camera interface, but the camera module requires 3.3V.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.