Pi HQ Cam with Jetson Nano using jetpack 4.6

Hi,

I have bought a raspberry pi hq cam and want to use it with the jetson nano dev kit.
I get these error messages:

[    1.742614] imx477 7-001a: tegracam sensor driver:imx477_v2.0.6
[    2.043048] imx477 7-001a: imx477_board_setup: error during i2c read probe (-121)
[    2.050615] imx477 7-001a: board setup failed
[    2.055121] imx477: probe of 7-001a failed with error -121
[    2.055637] imx477 8-001a: tegracam sensor driver:imx477_v2.0.6
[    2.356047] imx477 8-001a: imx477_board_setup: error during i2c read probe (-121)
[    2.363600] imx477 8-001a: board setup failed
[    2.368064] imx477: probe of 8-001a failed with error -121

~$ dmesg | grep -i tegra-vii2c
[    2.042963] tegra-vii2c 546c0000.i2c: no acknowledge from address 0x1a
[    2.355954] tegra-vii2c 546c0000.i2c: no acknowledge from address 0x1a

So while searching for a solution I found this post:
Raspberry Pi HQ camera with Jetson Nano
which suggests to remove the R8 resistor since the hq cam needs 3.3V for for reset GPIO in the camera interface.

When I run the jetson-io configuration tool and select imx477 I see the following:

Here it says 3.3V.

I am not quite sure if removing the R8 is still needed. For me it at least does not work without removing but I am a little hesitant removing the resistor.

Anything else I need to consider when using HQ Cam with imx477 on the jetson nano dev kit using jetpack Version: 4.6.1-b110 before I try to remove the resistor?

according to this page… [Raspberry Pi HQ camera IMX477 Driver | Linux driver for Jetson | RidgeRun], a resistor labeled as R8 must be removed.

Hi,

my problem was solved after i removed it.

Kind regards

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.