Problems using initrd_flash with nvme but without A/B boot

We’re having trouble getting the l4t_initrd_flash.sh script to work correctly on our nvme SSD. When we flash it using the ROOTFS_AB=1 option and the appropriate XML file flash_l4t_nvme_rootfs_ab.xml it works as expected.

However I’d like to be able to work with it using a non-A/B approach instead. If I remove the ROOTFS_AB option and use flash_l4t_nvme.xml I get this error:

Error: Return value 4
Command tegraparser_v2 --generategpt --pt flash.xml.bin
Error: /home/zik/mtdata/flash_ssd/img/0.1.38/bootloader/signed/flash.idx is not found
Error: failed to relocate images to /home/zik/mtdata/flash_ssd/img/0.1.38/tools/kernel_flash/images

I’m not sure why this error is occurring when using the non-A/B approach when the A/B approach is working fine.

The command I’m using is:

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1 -S 40GiB --showlogs -c ./tools/kernel_flash/flash_l4t_nvme.xml jetson-xavier-nx-devkit-tx2-nx external

We’re using JetPack 4.6.3.

Any suggestions?

hello zsaleeba,

could you please refer to readme file, you may check Workflow 3 for steps to flash to an external storage.

Thanks Jerry. Those are the instructions I’m following. I’m using workflow 3.

As well as the command line above I’ve also tried this variant:

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1 -S 40GiB --showlogs -c ./tools/kernel_flash/flash_l4t_nvme.xml jetson-xavier-nx-devkit-tx2-nx nvme0n1p1

Either way the same error occurs.

hello zsaleeba,

it might be an issue that mismatch designated folder so you cannot relocate the images.
could you please try review your JetPack installation folder. please check you’ve delete temporary folder and execute the script again.

Hi Jerry,

I’ve fixed the problem - it was related to the number of sectors declared in flash_l4t_nvme.xml not being adequate.

Thanks for your help.

1 Like