Problems using Intel Realsense D435

Hello All,

I followed the instructions here: (https://www.jetsonhacks.com/2019/01/21/intel-realsense-d435i-on-nvidia-jetson-agx-xavier/)
to install the realsense libraries on my Xavier.
It completed successfully.

When I tried to build the ROS wrapper for my camera (https://github.com/IntelRealSense/realsense-ros/tree/2.0.1#step-1-install-the-latest-intel-realsense-sdk-20)
I was greeted with these errors:

CMake Warning at realsense-ros/realsense2_camera/CMakeLists.txt:37 (find_package):
  Could not find a configuration file for package "realsense2" that is
  compatible with requested version "2.22.0".

  The following configuration files were considered but not accepted:

    /usr/local/lib/cmake/realsense2/realsense2Config.cmake, version: 2.17.1
CMake Error at realsense-ros/realsense2_camera/CMakeLists.txt:39 (message):
   Intel RealSense SDK 2.0 is missing, please install it from https://github.com/IntelRealSense/librealsense/releases

So, I tried to install the SDK, and I can never install librealsense2-dev or -dbg because they do not support ARM64…

How should I proceed to get the ROS wrapper working for my camera?

Hi luke.rector,

The AGX Xavier is Ubuntu 18.04, but the supported version on below instruction is Ubuntu 16.04, not sure if that’s the cause of your issue: https://github.com/IntelRealSense/realsense-ros/tree/2.0.1#step-1-install-the-latest-intel-realsense-sdk-20

Thanks

Hi Kayccc,

Well, that definitely makes sense… I am on 18.04.
I have the “Real sense viewer” working (through jetson hacks’ post), but it seems I’ll have to find another solution for linking it to ROS.
I’m going to be using it for object detection, so if anyone has any suggestions they would be appreciated.

Thanks,
Luke

I figured it out.

This line in the JetsonHacks librealsense2 script needs to be changed from:

LIBREALSENSE_VERSION=v2.17.1

to:

LIBREALSENSE_VERSION=v2.23.0

Good to know you resolved the problem, thanks.

luke.rector: Can you give some idea as to your streaming performance inside of ros? I have noticed that, with my d435i, the rs_rgbd.launch node frequently crashes and re-launches, even at 424x240@15fps (the lowest possible resolution). Any information you can provide would be very helpful.

Specifically:

Are you using the d435i or the d435? What camera firmware were you using?

Did you follow all of the steps in the buildLibRealSense repo you mention above? Did you have to do anything differently?

What stable frame rate were you able to achieve using the realsense-viewer? I have observed frequent USB SCP Overflow errors and dropped frames at (resolutions as low as) 640x480@15fps and I followed the same Jetson Hacks work-through that you mention.

Which version of ros are you using? Melodic? Kinetic?

Many apologies for my delayed response.
I have been seeing “good enough” performance in our D435 camera.
Firmware: 05.09.02.00
With the resolution at 640 x 480 I am getting stable 30 FPS in RealSense Viewer.
I believe I followed all the other steps in the repo instructions, but I was not able to update my firmware to the latest version… I think it has something to do with the embedded system in the Xavier.

I have found that I get the most stable framerates (and avoid overflow errors / frame drops) both in the Viewer and in RVIZ when I lower the resolution to 640 x 480, and disable all un-needed camera features such as infrared.

I am using ROS Melodic.