How to connet intel realsense 435i to agx xavier under jetpack4.2

Now I want to connect intel realsense 435i to agx under Jetpack 4.2.
I have no idea how to do this.
Waiting for your help~~

Suppose it’s USB device should be able plug and play for it.
Have reference to below link.

thank you so much !I find a video about agx and 435i.But When I run ./buildpatchedkernel ,agx have not enough space. Is this true?

Please use the update version of that article, you do not have to build the kernel unless you understand what features that would disable and enable. The Github repository is here:

The Intel instructions are here: librealsense/installation_jetson.md at master · IntelRealSense/librealsense · GitHub

thanks.
but my agx has jetpack4.2(L4t 32.1.0),it seems this method do not support my version.

You are facing multipleissues. The firmware of the RealSense camera is tied to the librealsense release. If you have updated your camera firmware, you may have issues with older versions of librealsense. There have been various fixes over the years to handle these cameras, both on the RealSense and Jetson sides.

Note that the following are no longer maintained.

Here is the original article for the Xavier:

For JetPack 4.2 on Xavier, you should be using:

As noted, this may not be compatible with the version of firmware in your camera.

Thank you so much for your help.
I download a docker images from the internet.And when I run camera in this docker,it shows that “Realsense ros v2.2.7 Running with LibRealsense v2.24.0”.

But it can not detect my camera,like"No Realsense devices were found".
Is it probably related to firmware version?
(In this images,librealsense can be compiled with no error.)

It is most likely caused by how you are talking to the camera through the Docker container, rather than librealsense itself.

Thank you for your reply.
This is what I did when I run docker.

alias camera=‘dir_name="$(date +%Y-%m-%d_%H-%M-%S)" && \mkdir -p /home/nvidia/Desktop/$dir_name/datasets && \tx2-docker run -e TZ=America/New_York --net host --privileged -v /dev/bus/usb:/dev/bus/usb -v /home/nvidia/Desktop/$dir_name:/root/rdpgo_ws/src/robust_distributed_slam_module/scripts/log -it lajoiepy/doorslam-realsensed435-tx2-dji camera $MASK $MASTER $OWN_IP $LOCAL_ROBOT_ID camera’

Is this command enough to let docker detect my camera?
Looking forward to your reply.

When I run this command it is like.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.