Proxmox 8 gpu passthru nvidia-smi no device found

I’ve spent a week reading logs, forums, etc, and trying all of the suggestions. I just can’t seem to get it to work.

I have a VM with Debian 11, and a K40m passed through with a device mapping.

I have already done this successfully with a 730 on another VM on the same physical machine, but the same steps aren’t working with the K40m.

I tried reading through the bug report, but it doesn’t tell me enough to get this working.

nvidia-bug-report.log.gz (80.9 KB)

  • I’ve tried both the nvidia-current, and nvidia-tesla-470 drivers.
  • I have nouveau blacklisted in the VM.
  • I have the device disabled on the node.
  • I’ve tried removing and re-adding the bridge.
  • I don’t see anything that says there are issues mapping memory, or saying there are power issues.
  • My sensors say that everything is running at 39 degrees C.

I see the driver loading, then it goes to RmInitAdapter failed

Aug 24 11:49:31 lapp kernel: [   12.772500] nvidia-nvlink: Nvlink Core is being initialized, major device number 248
Aug 24 11:49:31 lapp kernel: [   12.773017] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  470.182.03  Fri Feb 24 03:29:56 UTC 2023
Aug 24 11:49:31 lapp kernel: [   12.998366] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  470.182.03  Fri Feb 24 03:18:06 UTC 2023
Aug 24 11:49:31 lapp kernel: [   13.266289] [drm] [nvidia-drm] [GPU ID 0x00000610] Loading driver
Aug 24 11:49:31 lapp kernel: [   13.266705] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:06:10.0 on minor 0
Aug 24 11:49:31 lapp kernel: [   23.179822] NVRM: GPU 0000:06:10.0: RmInitAdapter failed! (0x22:0xffff:667)

Any help?