PyTorch for JetPack 6.0DP

I see that a PyTorch wheel is available for JetPack 6.0DP:
https://developer.download.nvidia.com/compute/redist/jp/v60dp/pytorch/

However the installation instructions seem to be out of date:

The following packages are not generally available for Ubuntu 22.04

  • g+±8
  • gcc-8
  • clang-8
  • lld-8
  • gfortran-8

I’m wondering if I can just omit the -8 suffix and use the latest versions of these packages.

Part 2 of this question is in the PyTorch installation command. I’m wondering if these versions numbers are still applicable to the latest JetPack/PyTorch installation:

python3 -m pip install aiohttp numpy==‘1.19.4’ scipy==‘1.5.3’ export “LD_LIBRARY_PATH=/usr/lib/llvm-8/lib:$LD_LIBRARY_PATH”

Hi @mattlichter, sorry about that - in my experience all those specific versions are unnecessary, but YMMV. You can try the install procedure from this thread which still worked for me on JetPack 6:

If you already have JetPack flashed, you probably don’t need to do much more than pip3 install xyz.whl

I also have full pre-built containers for these on JetPack 6 over at jetson-containers, including PyTorch/torchvision/ect:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.