Quadro K2100M and Nsight 4.0

I am trying to get Cuda SDK and Parallel Nsight up and running on my new Thinkpad W540 (with Windows 8.1 and CUDA SDK 6.0). It has a Quadro K2100M, which I beleive is fairly new, and Nsight monitor reports an error: “A CUDA context was created on a GPU that is not currently debuggable.” when I try do debug the Nsight demo projects. Could this error mean that Quadro K2100M is not yet supported by Nsight?

If you have a version lower than 4.0.0.14066, download the new version from https://developer.nvidia.com/rdp/nsight-visual-studio-edition-early-access

You’ll need to sign up for the registered developer program if you are not already.

Could you be specific about which version of Nsight 4 you are currently running?

I am using NSight version 4.0.0.14066 that was packaged with CUDA 6 Production Release.

Right now the version of Nsight VSE here:

https://developer.nvidia.com/rdp/nsight-visual-studio-edition-early-access

is 4.0 RC1

My suggestions is to wait until 4.0 RC2 is published there and try again. I don’t know when that will be exactly, but it should be the next version published there.

It works after installing the 334.95 drivers and NSight 4.0 RC2.

For anyone curious, Visual Nsight RC2 is build version 4.0.0.14118 and the current 4.0 release is build # 4.0.0.14159.