Quadro P5200 Power / Performance problems in Manjaro | Ubuntu on DELL Precision 7730

While researching what seems to be Manjaro specific extremely low performance on battery problem
https://forum.manjaro.org/t/dell-workstation-huge-performance-problem-on-battery/74040
i believe i’ve found power-related bug which is universal to my setup and most likely nvidia driver related, checked it on Ubuntu (which DELL claims to “officially support”) - also happens there.

  1. After boot on AC
    Heavy load Graphics 1708 mHz / Memory 7230 mHz
    FAN can go REALLY hard on any load

  2. BAT
    Heavy load Graphics 427 mHz / Memory 7230 mHz
    FAN doesn’t go REALLY hard on any load

  3. After switchin back to AC
    Heavy load Graphics 427 mHz / Memory 7230 mHz

By heavy load i mean games like Native Hitman 2016, 3D modeling, 4k video…Well all the usual stuff that should crank CPU/GPU.

If you just load on AC everything is fine, clocks can go max, but any battery/AC swtich cause this to not recover max performance until reboot.

In short in manjaro thread i’ve tried disabling tlp, powermizer, forcing tlp to full max, forcing powermizer to max etc - nothing changes this behaviour.
So i suspect this bug could possibly be connected with Manjaro performance problem, but after trying Ubuntu i guess this is separate nvidia driver related issue.

Now i’m on clean Manjaro Deepin, updated and installed latest Nvidia 415.27
Here’s my system specs. inxi -Fxxz

System:    Host: x133-pc Kernel: 4.19.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Deepin 15.9 tk: Qt 5.12.0 
           wm: DeepinWM dm: LightDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Precision 7730 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 0VC5H3 v: A00 serial: <filter> UEFI: Dell v: 1.5.2 date: 11/01/2018 
Battery:   ID-1: BAT0 charge: 94.1 Wh condition: 94.1/97.0 Wh (97%) volts: 12.9/11.4 model: BYD DELL GW0K986 serial: <filter> 
           status: Full 
CPU:       Topology: 6-Core model: Intel Core i9-8950HK bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 69720 
           Speed: 800 MHz min/max: 800/4800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 801 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: NVIDIA GP104GLM [Quadro P5200 Mobile] vendor: Dell driver: nvidia v: 415.27 bus ID: 01:00.0 
           chip ID: 10de:1bb5 
           Display: x11 server: X.Org 1.20.3 driver: nvidia resolution: 3840x2160~60Hz 
           OpenGL: renderer: Quadro P5200/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: NVIDIA GP104 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f0 
           Sound Server: ALSA v: k4.19.16-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           chip ID: 8086:15bb 
           IF: eno1 state: down mac: <filter> 
           Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 3000 bus ID: 6f:00.0 chip ID: 8086:2526 
           IF: wlp111s0 state: up mac: <filter> 
Drives:    Local Storage: total: 267.35 GiB used: 36.56 GiB (13.7%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: PM981 NVMe 256GB size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> 
           ID-2: /dev/sda type: USB vendor: Kingston model: DataTraveler 3.0 size: 28.88 GiB serial: <filter> 
Partition: ID-1: / size: 54.30 GiB used: 7.70 GiB (14.2%) fs: ext4 dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A gpu: nvidia temp: 52 C 
           Fan Speeds (RPM): cpu: 0 fan-2: 0 
Info:      Processes: 264 Uptime: 1m Memory: 62.75 GiB used: 988.0 MiB (1.5%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 5.0.0 running in: deepin-terminal inxi: 3.0.30

My configuration:

https://www.dell.com/en-us/work/shop/pdr/precision-17-7730-laptop/xctop7730hwus?selectionState=eyJPQyI6InhjdG9wNzczMGh3dXMiLCJNb2RzIjpbeyJJZCI6MywiT3B0cyI6W3siSWQiOiJHV1BBRjU3In1dfSx7IklkIjo0LCJPcHRzIjpbeyJJZCI6Ikc0SFMxVFIifV19LHsiSWQiOjYsIk9wdHMiOlt7IklkIjoiR0hMWkY5SiJ9XX0seyJJZCI6NywiT3B0cyI6W3siSWQiOiJHMlQ0TUgwIn1dfSx7IklkIjo4LCJPcHRzIjpbeyJJZCI6IkdCVEtTOE8ifV19LHsiSWQiOjExLCJPcHRzIjpbeyJJZCI6Ikc1S0FZMjMifV19LHsiSWQiOjE5LCJPcHRzIjpbeyJJZCI6IkdITEQ4VkIifV19LHsiSWQiOjExMiwiT3B0cyI6W3siSWQiOiJHNERSMllQIn1dfSx7IklkIjoxNDYsIk9wdHMiOlt7IklkIjoiR0NCV1pVMiJ9XX0seyJJZCI6MTQ5LCJPcHRzIjpbeyJJZCI6IkdNQUxHNlcifV19LHsiSWQiOjM3MiwiT3B0cyI6W3siSWQiOiJHM1c1QzZIIn1dfSx7IklkIjo3NDksIk9wdHMiOlt7IklkIjoiRzhCWFdZSSJ9XX0seyJJZCI6NzYwLCJPcHRzIjpbeyJJZCI6IkdZQUpCMU0ifV19LHsiSWQiOjEwMDIsIk9wdHMiOlt7IklkIjoiR0VLSDhVUSJ9XX0seyJJZCI6MTAwMywiT3B0cyI6W3siSWQiOiJHUTZUWDQ4In1dfV19&cartItemId=

I’ve repeated above steps 1-3, then sudo startx – -logverbose 6 and nvidia-bug-report.sh

P.S. If anyone have any suggestions and help in original Manjaro thread considering performance on battery, which accidently have lead to finding this one - please feel free :)
nvidia-bug-report.log.gz (1.02 MB)

Please install acpid and see if that helps.

Manjaro pamac reports that acpid v2.0.31-1 is installed, should i try to force activate it somehow?

Probably using systemctl (as root):
Status:
systemctl status acpid
start:
systemctl start acpid
enable to start on boot:
systemctl enable acpid

Thx, yeah it was loaded, but inactive (dead)

So now sudo systemctl status acpid

● acpid.service - ACPI event daemon
   Loaded: loaded (/usr/lib/systemd/system/acpid.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2019-02-07 15:41:44 MSK; 7min ago
     Docs: man:acpid(8)
 Main PID: 544 (acpid)
    Tasks: 1 (limit: 4915)
   Memory: 3.3M
   CGroup: /system.slice/acpid.service
           └─544 /usr/bin/acpid --foreground --netlink

feb 07 15:46:33 x133-pc root[1919]: ACPI group/action undefined: processor / LNXCPU:04
feb 07 15:46:33 x133-pc root[1940]: ACPI group/action undefined: processor / LNXCPU:06
feb 07 15:46:33 x133-pc root[1962]: ACPI group/action undefined: processor / LNXCPU:08
feb 07 15:46:33 x133-pc root[1973]: ACPI group/action undefined: processor / LNXCPU:09
feb 07 15:46:33 x133-pc root[1996]: ACPI group/action undefined: processor / LNXCPU:0b
feb 07 15:47:30 x133-pc root[2331]: ACPI group/action undefined: processor / LNXCPU:01
feb 07 15:47:30 x133-pc root[2366]: ACPI group/action undefined: processor / LNXCPU:05
feb 07 15:47:30 x133-pc root[2368]: ACPI group/action undefined: processor / LNXCPU:06
feb 07 15:47:30 x133-pc root[2374]: ACPI group/action undefined: processor / LNXCPU:09
feb 07 15:47:30 x133-pc root[2376]: ACPI group/action undefined: processor / LNXCPU:0a

Starting and enabling acpid haven’t helped with this issue, though ACPI group/action undefined: processor sounds worrying

You can safely ignore that message, it just tells that there’s no script making use of that signal, it’s normal.
Does the unlug/plug of the AC adapter getting noticed by nvidia-settings->powermizer pane? Just to make sure, did you reboot after enabling the acpid? Did you try a different driver beforehands to see if this is a regression or a general bug?

It also shouldn’t hurt to check for a bios update.

I have checked few days ago had latest v1.5.2, now there’s v1.6.0 available will update now and check!

Yes, that’s how i monitor GPU stats mentioned in original post.
When i unplug and go to BAT mode it behaves as described:
Heavy load Graphics 427 mHz / Memory 7230 mHz
FAN doesn’t go REALLY hard on any load

After plugging back to AC i believe PowerMizer still changes it’s state (by that i mean it can go to Perf level 3), but Graphics frequency never go higher than 427 mHz.
Just as FAN still can’t go really hard (this is really noticeable on gaming)

Yes

On Manjaro i used only 415.27
On Ubuntu i used 415, 396, 390
In regards to this issue they behave same

Updated to bios v1.6.0
Tested on Ubuntu 18 LTS with 415.27, Manjaro Deepin 415.27 - nothing changed.

Do i need to force reinstall nvidia drivers after bios update, or it’s ok to test as is?

btw, in BIOS i’ve tried to exclude everything that could possibly interfere:
SATA Operation / AHCI
DELL Type-C Dock configuration / Always allow Dell docks - disabled
Thunderbolt adapter configuration / No security
Switchable Graphics - Disabled
Security / Absolute - Disabled
Secure boot - Disabled
Intel SGX - Disabled
Fastboot - Minimal (only Minimal / Through / Auto = Minimal are available)
Wireless device enable / WWAN, GPS, Bluetooth - off

No need to reinstall the driver.
Things to try:

You mean sleep after AC/BAT/AC?
Tried it, after suspend graphics frequency still stays max 427 mHz

That’s not possible, this DELL have only Quadro P5200, switch in BIOS is actually leftover of generic bios i suppose.
I specifically targeted workstation without Optimus / Hybrid btw, because of how much i hate this drivers and how many problems i had with them before :)

ok, then that’s not an option.
That device came with Ubuntu 18.04 pre-installed, did the nvidia gpu behave normally with that?

I’ve get this one in november it came with Ubuntu 16 LTS back then, Ubuntu 18 LTS they started to officially ship with / support just few days ago.

Considering visible performance both was fine as far as i can tell, no noticeable lags etc.
But at times i was testing with shipped 16 i haven’t really tested heavy load on battery.

So i suppose most likely it was same, at least now on Ubuntu 18 LTS this issue is active

P.S. Just in case hardware is definately not faulty, i’ve tested everything i could with Windows 10, nothing like that happens there at all.

No, the hardware isn’t faulty but I suspect the ACPI needs a special tweak to be set to work properly with linux, that’s why I asked about the initial install.

Yeah, i had that suspicion too, before installing Ubuntu 18 LTS i asked DELL support to clarify if there’s anything i should know before installing clean on new SSD, they said there shouldn’t be anything additional and just installing 18 as is should be good…

But who can trust support this days, so i’m not sure)
Sadly original SSD with preinstalled 16 is not an option now, since it’s whiped…

Please run
sudo acpidump > acpidump.txt
and attach that, maybe some switch can be found.

Says command not found, i’ve installed acpi-tools still not found…

Use this:
https://www.archlinux.org/packages/community/x86_64/acpica/

Oh sorry, i thought you meant on Ubuntu, here you go:

sudo acpidump > acpidump.txt on Manjaro Deepin:

acpi_m.txt (1.68 MB)

Only extra switches:
Linux-Dell-Thunderbolt
Linux-Dell-Video (already set by the kernel)
You could try to mimic Windows 8 using kernel parameter line

acpi_osi="!Windows 2017" acpi_osi="!Windows 2015" acpi_osi=Linux-Dell-Thunderbolt acpi_osi=Linux-Dell-Video