[R28.2 mmapi] Crop rect's right out of boundary

hello , i am using R28.2 release.
I tested the MMAPI’s demo, 08_video_dec_drm. When I enter the stress test parameters, an error occurs and the DRM decoding display is not able to run the second time.

./video_dec_drm …/…/data/Video/sample_outdoor_car_1080p_10fps.h264 H264 -s 4

Start the iteration: 2

Failed to query video capabilities: Inappropriate ioctl for device
NvMMLiteOpen : Block : BlockType = 261 
TVMR: NvMMLiteTVMRDecBlockOpen: 7647: NvMMLiteBlockOpen 
NvMMLiteBlockCreate : Block : BlockType = 261 
Failed to query video capabilities: Inappropriate ioctl for device
Starting decoder capture loop thread
TVMR: cbBeginSequence: 1179: BeginSequence  1920x1088, bVPR = 0
TVMR: LowCorner Frequency = 0 
TVMR: cbBeginSequence: 1529: DecodeBuffers = 5, pnvsi->eCodec = 4, codec = 0 
TVMR: cbBeginSequence: 1600: Display Resolution : (1920x1080) 
TVMR: cbBeginSequence: 1601: Display Aspect Ratio : (1920x1080) 
TVMR: cbBeginSequence: 1669: ColorFormat : 5 
TVMR: cbBeginSequence:1683 ColorSpace = NvColorSpace_YCbCr601
TVMR: cbBeginSequence: 1809: SurfaceLayout = 3
TVMR: cbBeginSequence: 1902: NumOfSurfaces = 12, InteraceStream = 0, InterlaceEnabled = 0, bSecure = 0, MVC = 0 Semiplanar = 1, bReinit = 1, BitDepthForSurface = 8 LumaBitDepth = 8, ChromaBitDepth = 8, ChromaFormat = 5
TVMR: cbBeginSequence: 1904: BeginSequence  ColorPrimaries = 2, TransferCharacteristics = 2, MatrixCoefficients = 2
Video Resolution: 1920x1080
APP_INFO : mastering display data not found
libv4l2_nvvidconv (0):(792) (INFO) : Allocating (17) OUTPUT PLANE BUFFERS Layout=1
libv4l2_nvvidconv (0):(808) (INFO) : Allocating (17) CAPTURE PLANE BUFFERS Layout=0
Query and set capture successful
libv4l2_nvvidconv (0):(1485) (INFO) : Crop rect's right out of boundary, set to MAXlibv4l2_nvvidconv (0):(1490) (INFO) : Crop rect's bottom out of boundary, set to MAXlibv4l2_nvvidconv (0):(1557) (ERROR) : Invalid Src Surface Count 0 
libv4l2_nvvidconv (0):(1692) (ERROR) : NVVIDCONV ERROR 4

Hi li, we can reproduce it. Will check and update.

Thank you, DaneLLL.
if there is a library update, it is best to put the new library in the attachment, to help me solve the problem as soon as possible

Hi li,
Please use prebuilt lib attached at
https://devtalk.nvidia.com/default/topic/1036111/jetson-tx2/-mmapi-decode-more-than-one-h264-file-get-problem-when-trying-to-modify-00_video_decode/post/5265055/#5265055