resume from suspend freezes system (GTX 970, Arch Linux, Kernel 4.4/4.7, NVIDIA 370)

How hard can it be to reproduce the problem really? You are a hardware company. Put together a system with the mentioned hardware. You need to buy a motherboard and a CPU, but chances are 95% that you already own what is needed. The you slot in one of your own GPU, most from the 9XX and 10XX families seem to crash the system. Install linux, Mint / Ubuntu / Fedora (probably any linux) with recent kernels with your recent proprietary driver crashes it.

We are many suffering from this and would be happy to troubleshoot further.
What I’d like to know, to decide if there is anything that can be done tweak-wise, is which systems does the suspend - resume with these GPUs work for?
Are 100% of these GPUs suffering from the issue or are we just 10% with bad hardware combinations?
Is it Skylake? Can I make it work by just switching to an older Mobo?

What does people know?

Which bugs are these listed as in kernel bugzilla / launchpad / redhat bugzilla?

Does anyone run linux with working suspend resume with Nvidia 9XX / 10XX? Please chime in.

@sandipt: I am running my system with the suggestions from #12 for 10 days now without any problems

I managed to replicate the issue again today. Maybe I need to start a new thread for my issue as my system seems to be responsive now, it’s just the display driver crashing?

My new bug report:
I also found that the driver doesn’t appear to crash immediately, but if I let the system sit long enough with my monitor cycling in and out of suspend (like it’s about to start displaying things again), dmesg eventually gives the following:

Really eager to do anything necessary to help resolve this.

happened again:

Tracking this issue under internal bug 200238391
I think most of ARClinux users are affected with this kernel.

I am having exact same problem on Ubuntu 16.04LTS with a new GTX 1060.
I had no problems with the same driver on my GTX 770.

Hi Buddy23, Can I get nvidia bug report as soon as issue reproduce ?


same issue here. After waking from suspend, Ubuntu goes well for like 30 sec, then the screen crash comes and cant recover the system so the power reset is the only solution.

GTX 1060 6GB OC Windforce+Ubuntu 16.04 with nvidia 367 or 370 drivers crashes after waking from suspend! I have also i7-6700 4 GHZ Skylake on a Z170X-Gaming-3 motherboard.

Could be a bios thing? The

I am trying several things on this but not discovered the error yet…

Downgrading the nvidia driver could be a solution? Wich is a good one to get for the GTX 1060 ?

Kind regards

Hi InfiniteMonkeys, Please attach nvidia bug report as soon as issue hit?


I am getting the exact same issue like the others. To trigger this freeze I simply had to suspend the system (I am using gnome, started with startx) and press a random button to resume it. It frooze, but by accident pressing Ctrl + Alt + F1 it switched to tty2. One thing I noticed was that the resolution was strange, it was kinda blurry and the font was weird.

I was able to start the nvidia report script, then I tried to switch back to tty1 where it was still frozen.

@sandipt I am going to send you the bug report per private message.

Thank You.

Hi crna, You can attach log to your existing post too.

Perhaps the virtual machine tried to change resolution, and you ran into the same issue that I reported here a long time ago. That issue only occurs when X has been running for a day or so, and gives the same call trace as you got. My report seems to have been ignored so far though, since the issue still happens for me with NVIDIA 370.28 and Linux 4.7.6.

perost, Looks you are facing some different issue which is not related to os suspend/resume.

sandipt: I’m not so sure of that, since popq got the exact same call trace as I get. I normally don’t use suspend/resume, but I just tried suspending my machine with “systemctl suspend”. And sure enough, the computer immediately froze in the exact same way as I describe in my other thread. So I think the chances are pretty high that we’re just seeing different symptoms of the same issue.

>>I just tried suspending my machine with “systemctl suspend”. And sure enough, the computer immediately froze in the exact same way as I describe in my other thread.

perost, Can you attach nvidia bug report ? Anyway we are able to repro this issue with suspend/resume on ubuntu 16.04 OS and investigating it.

I’ve already done that in my other thread.

>>I’ve already done that in my other thread.

that bug report is old one and also has different reproduction steps. I need latest bug report when you repro issue with suspend/resume so I can check backtrace and dmesg errors.

Ok, I’ll see if I can make a new trace later, the issue only occurs after my computer has been running for 24 hours or so. At the moment it’s only been 15 hours since the last reboot, so suspend is currently working fine for me.

Hi, I’m quite certain that I’m having the same problem as the OP on Linux Mint 17.3, 18.0 and also the just released Ubuntu 16.10. Besides 3 different versions of Linux, I have also tried different kernels ranging from 3.16 up to 4.9 nightly build. I have tried nouveau, nvidia proprietary drivers 367 and 370. Basically I’ve spend about 2 full days now trying to figure out a solution. I absolutely need suspend cause the PC pulls 80 Watts in idle mode, and switching it off overnight is not really an option as I always have tons of programs open (it is a WORKstation after all).

So whenever I suspend the PC, it simply won’t wake up from sleep anymore (it won’t resume) and all I get is a black screen. After about half a minute the computer then switches itself off and tries again. But that attempt doesn’t work either so all I can do is manually switch off the PC by pressing the power button for a long time. After that I can boot in a normal way.

Intel 5820K
Asus X99-A II with latest bios.
128 GB RAM
GTX 1070

How to create an ‘nvidia bug report’ ?

The will collect information about your system and create the file ‘nvidia-bug-report.log.gz’ in the current directory. I think this available in /usr/bin/