Problem with resume from suspend (Ubuntu 16.04, GT 940MX)

Hi all!

I have a problem with suspend on my laptop. When I push space or enter in order to wake up I get black screen. if I try ctrl+alt+f1 nothing happens.

-Asus x556 (GT 940MX)
-Ubuntu 16.04 (4.8.0-58 generic)
-Nvidia-smi 381.22

Bug report included.
nvidia-bug-report.log.gz (140 KB)

Issue reproduction steps are not much clear. In log there is not any error related to nvidia. Can you please share video recording showing this issue? Also you should report this issue for Canonical also as this is PRIME setup with modeset driver.

try this

step by step:

  1. turn on notebook and do some work for example
  2. then press suspend button in right top corner by mouse
  3. notebook goes sleep (display and coolers turn off)
  4. waiting for 5 sec and then I press space or enter
  5. It seems notebook is turning on but I get black screen and that’s all
  6. then I press power button in order to turn off notebook
  7. again turn on and run nvidia bug script

thank you! hibernate working well, but suspend still not working

Some steps to debug:
0. Start your laptop normally, don’t suspend.

  1. Stop your displaymanager: sudo systemctl stop display-manager
  2. You should now be on text console, log in.
  3. Get a root shell: sudo -s
  4. Load bbswitch if not already loaded: modprobe bbswitch
  5. Turn off nvidia gpu: echo “OFF” >/proc/acpi/bbswitch
  6. Check status: cat /proc/acpi/bbswitch
  7. Turn on nvidia gpu: echo “ON” >/proc/acpi/bbswitch
  8. Check status: cat /proc/acpi/bbswitch
  9. dmesg >dmesg.txt
  11. Post both files here

Is it possible for you are do remote ssh to you linux system and generate nvidia bug report as soon as issue hit. I want to see logs when you see black screen on desktop. Are you able to switch to VT/console when seen black screen. If yes, you can run nvida bug report from there as well. *** /var/log/Xorg.1.log showing X fail to start with below error :

[  1073.394] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[  1073.394] (EE) NVIDIA:     system's kernel log for additional error messages and
[  1073.394] (EE) NVIDIA:     consult the NVIDIA README for details.
[  1073.395] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[  1073.395] (EE) NVIDIA:     system's kernel log for additional error messages and
[  1073.395] (EE) NVIDIA:     consult the NVIDIA README for details.
[  1073.395] (WW) Falling back to old probe method for modesetting
[  1073.395] (EE) No devices detected


From *** /etc/X11/xorg.conf looks like you are using default “modesetting” driver with nvidia driver for PRIME to work. Can you release “modesetting” driver with “Intel” and then test by starting X. I think you need XOrg intel driver package to do it.

Hello, I am experienceing this issue as well on an ASUS UX560U.

I tried going to nvidia-settings and using the Intel PRIME setting. I tried to log out and log in as suggested by nvidia-settings but that didn’t work (login screen loop). A reboot worked and I checked nvidia-settings which said I’m on the Intel profile. A suspend and resume worked with this settings.

However, switching back to the NVIDIA PRIME profile, logging out, not being able to log in properly, rebooting and making sure nvidia-settings reports NVIDIA PRIME - waking up from suspend did not work.

This made my suspect the problem is indeed an NVIDIA problem and not kernel related as my other research suggested. BTW, what is a PRIME profile? And if using the NVIDIA one the driver switches depending on graphics usage to preserve battery?

I do not use hibernation so I’m not checking it.

As per the link @mounir posted - I tried updating the initramfs and adding the boot options in grub (grub edit mode, not permanent) but that did not work. I did not try the policy-kit steps as they seemed irrelevant. Maybe this is not for the scope of this post and I should reply on mounir’s?

I hope I can get this working soon.

And also, I grepped up all of the Xorg.*.log files for NVIDIA or EE relating to that so I might find something such as the snippet @sandipt posted. There were none! That’s strange, so I also ask if this means that my problem is not NVIDIA related after all or maybe something else is fishy about the logs?

I’ve connected via ssh to my notebook.
This is new bug report
nvidia-bug-report.log.gz (142 KB)

Was this log generated as soon as issue hit? I didn’t see any nvidia related error in log.

Might be acpi related. Please run acpidump and attach to you post.

When I was trying to wake up after suspend, I get black screen. After that I used ssh to connect to laptop and run nvidia bug report.

try to add your ethernet card to sleep modules and check if you have powerwaked installed .

H all,

I am facing the same problem. I had thought my issue was this related to this forum - I had made posts there, and then sandipt had said solution is on the way, but 381 came, and I still have the same problem.

Now I’m sure I am facing the same problem as this particular thread talks about as -

  1. Laptop is Asus R558U (930MX)
  2. Tried Ubuntu 17.04, 16.04, Mint 18.1, 18.2, Solus, Fedora 26. Everywhere the same issue is there.
  3. Sleep-Resume works with no problems with nouveau. It works fine with nvidia-prime setting (in Ubuntu/Mint) choosing Intel graphics (power saving mode).
  4. It does not work when ONLY when the system runs on nvidia graphics.
  5. I tried with many kernel versions (stable, unstable, everything) from 4.8 onwards.
  6. Tried latest BIOS update as well.

From this much it is clear that this is an nvidia issue and not something else entirely.

Hi Sandipt,

Please look into this matter asap, and reply whatever diagnostics you need. I had given syslogs before in the other thread. I’m including it below as well. Also included is the nvidia-bug-report. (Also included is a video taken in June when I was trying with Kubuntu, I had posted this video in the other thread as per your suggestion).

I’m hoping to resolve this issue which is affecting me since I bought this laptop 6 months back. I am not expecting replies 2-3 days spaced which keep asking to try out minor things. That is not how support works. I am also an engineer and I’ve worked support too. Take this seriously, it is clear that so far the nvidia support for Linux is pathetic. To say the least.

Hoping to get something done.

Link -

Hi Jones,
wondering if you solved this issue… I’m experiencing the same problem in my ASUS laptop and haven’t been able to find a solution. It’s very annoying not being able to Suspend/Hibernate when wanted or needed and brute force a restart.
Thanks for any help you may give me.

Hi Boris,

No, I still have no solution to this problem.

In case you ever independently get a solution, please update here or PM me.




If a new thread is to be created, at least tell that.

same problem here. It is very annoying. I have Dell Precision 7520.

How about providing nvidia-bug-report logs? SuperCat provided one but that was without any trace of an error, so it’s impossible to find anything.

Same here, very annoying. Asus ZenBook UX530UX with GeForce GTX 950M running dual boot Ubuntu 16.04 alongside windows. As one may expect, on windows side I have no problem putting the computer to sleep (no cuda / nvidia drivers installed on the windows partition). But can’t sleep or hibernate the computer from the Linux side (has cuda / nvidia drivers) - must shutdown everytime, very very annoying.

same here.every time i suspend my laptop, i get a black screen after opening the lid and thats it. MSI cx62 nvidia geforce940mx, ubuntu 16.04 dual boot with windows