RmInitAdapter failed! error produced when I try to passthru my GTX 1060 to a Linux/Ubuntu/bhyve VM (instead,my RTX 2080ti is passed correctly)

Hello to everyone.

I’m trying to passhtru my GTX 1060 from my host os (FreeBSD 13.1-RELEASE) to a Linux/Ubuntu VM virtualized with bhyve,but unsuccessfully. Last year I tried to do the same with another GPU that I have on my PC,the RTX 2080 ti and with the help of @generix,after a tricky trouble shooting we have been able to do that. Point is that th same patches which worked (and that works right now) for the 2080 ti aren’t working for the GTX 1060. The error that I see is the same that I saw when I have cooperated with Generix for passing thru the 2080 ti :

0) # nvidia-smi : No devices were found

1) # lspci : https://pastebin.ubuntu.com/p/mTZR2vhFHv/

2) full dmesg LOG : https://pastebin.ubuntu.com/p/rZMDGsQDj6/

3) # cat /proc/cpuinfo : https://pastebin.ubuntu.com/p/x5djTNwNKP/

4) xorg log : https://pastebin.ubuntu.com/p/cTvyBjz9cR/  

5) # nvidia-xconfig --query-gpu-info

WARNING: Unable to use the nvidia-cfg library to query NVIDIA hardware.
ERROR: Unable to query GPU information

6) # sudo lspci -d "10de:*" -v -xxx : 


what else info do you need ? I really would like to know which hardware difference there are between the two gpus because for the 1060 Im using the same new driver that I’m using for the 2080 ti and the latter one can be passed without problems. Anyway,I would know what should I do to fix that error. Very thanksful.