"RmInitAdapter failed" on GT 8800 with driver 340.107, kernel 4.14.101-gentoo on MacPro3,1

I installed what I understand is the most recent nVidia and Gentoo supported kernel (4.14.101-gentoo) with the Gentoo suggested nVidia driver, 340.107, on a system running systemd and where I am attempting to start by simply running X. I can boot the system without errors, but when I modprobe nvidia, the screen goes blank and dmesg gives me the “RmInitAdapter failed! (0x25:0xffffffff:1197)” message. This is before I even get a chance to start X. Things I have tried: (1) using kernel parameter pcie_aspm=off. Increasing the default GPUs in the kernel from default of 16 to 120. Neither of these helped. I also tried using nouveau to see how it would do. By default nouveau gives me some PFIFO_READ and PT_NOT_PRESENT errors unless I used noaccel=1. With this latter module parm, I get X, but with lots of artifacts on the screen–basically unusable. The nouveau test was done with the newest kernel and nouveau (4.19.23-gentoo). As said, my test with nVidia has only been with 4.14.101-gentoo. All tests reported here are with gentoo, although I also have an Arch system on the machine with similar results, although I have only used Arch’s newest kernels in testing nouveau and nVidia. The results are the same. The machine boots via UEFI and Grub (for Gentoo). I also have tried rEFInd for use with Arch.

Attached is the output from nvidia-bug-report tool. Thank you for any advice you can provide.

PS: I don’t see how to attach output here
nvidia-bug-report.log.gz (36 KB)
rEFInd.png
rEFInd2.png
nouveau.png

Sounds like the GT 8800 is simply broken.
Attaching files:
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

@generix: thanks for the tip about attaching files. I’ve done that now. I hope the GT 8800 isn’t broken. The machine used to boot up Mac OS X, I’m told, but I hear that was four or five years ago. Since then, though, it’s just been sitting without even being turned on.

Doesn’t look any better. Maybe it’s just oxidized, try removing and reseating the card and power connectors, if that doesn’t help, ditch it.

(1) Suggested fix attempted, no luck.

Before submitting the bug report, I had already tried the graphics
card in both of the available x16 slots without seeing any difference
on the screen. I’ve also tried each of the card’s DVIs. Following up
on @generix’s suggestion, I pulled the card and cleaned the gold
fingers with a clean eraser, and carefully examined them under
magnification. I see no sign of oxidization or wear. Looking at
nearby similar components with gold fingers, namely the two rather
large memory cards, I see no signs of oxidization or wear with them
either.

(2) Additional information on artifacts and lack thereof:

My original post was rather lacking on a description of the screen
output. I have attached three pictures to help show the situation.
The first two graphical screens are from the rEFInd
bootloader and are perfect. Next comes a scrolling text screen
showing systemd bootup. There are no artifacts there either. It’s
not until nouveau is loaded that I see the artifacts shows in the last
picture. With the nvidia driver, you could say things are better
because the screen simply goes black without artifacts of any kind.

In short, until nouveau or nvidia is loaded, the bootloader graphical
screens and the booted text screens are flawless. With nouveau, I get
X, but artifacts. With nvidia, I get no artifacts, just a black
screen, probably because of the dmesg messages reported, like
“RmInitAdapter failed.” I can see this situation even more clearly
when I load these modules manually.

(3) Similar problems (“RmInitAdapter failed”) that have been submited
appear to have been addressed:

e.g.,
https://devtalk.nvidia.com/default/topic/1001941/linux/-quot-rminitadapter-failed-quot-with-378-13/post/5214362/

even more similarly perhaps: @sandipt
https://devtalk.nvidia.com/default/topic/959156/linux/-quot-rminitadapter-failed-quot-with-370-23-but-367-35-works-fine/1

(4) Still seeking a solution:

According to nVidia pages, this card is still supported through the
end of 2019. To simply “ditch the card” would, in all practicality,
mean ditching the entire machine, because cards for this machine are
next to impossible to come by. And I say in all practicality, because
of course you can put a newer card in the machine if you flash it with
Mac BIOS and put in a second PSU. I see no reason to pursue these
extremes if it’s a software bug that should be righted.