Running directX games will freeze my whole system on 3050 mobile running on hybird as defult archinstall script)

nvidia-bug-report.log.gz (637.0 KB)

there’s something i notice on these three direct x games that it will freeze after few min of playing that even ctrl+alt+f3 won’t help and even and no matter how heavy or lightweight the game

the games i have tested: A hat in time+overwatch2+astroneer ( all of them are directX games)

OS:archlinux
nvidia driver version:550.54.14
DE: kde plasma 6 and still useing x11

Please post the output of

sudo cat /sys/module/nvidia_drm/parameters/modeset

Do you use offloading to start those games on the nvidia gpu? i.e. by prepending
__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia

Furthermore, your intel igpu doesn’t seem to have vulkan support installed.

image i got this insted and nothing changes

and the output of /sys/module/nvidia_drm/parameters/modeset is just the letter N

Please set kernel parameter nvidia-drm.modeset=1
After reboot, the output of the command should change to Y instead of N.
Pre-pending, not appending, e.g. running in a terminal
__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia <yourgamebinary>
or install and use prime-run to start your game.

1 Like

Thanks for your help. Unfortunately, that’s not the end of the problem, but at least I got more details about it.

There’s a new log after I enabled nvidia-drm.modeset and tried using prime-run.

Here are some things I noticed:

  1. Updating or reinstalling the game makes it work fine, but only on the first launch. It never works again until I reinstall it or install another update.
  2. The freeze appears on the loading screen or when the game loads some assets.
  3. All the games I tested that have this problem are Unreal Engine games.
  4. Adding nvidia-drm.modeset didn’t change the freezing issue, but it did fix Wayland tearing, so it was useful anyway.

nvidia-bug-report.log (5.7 MB)

5-forgot to say but if i run only useing intel graphics it will work well even that it’s weaker

also there’s proton log
steam-253230.log (223.3 KB)

Since you run it from steam, don’t start steam using offloading but add
__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia %command% to game startup options within steam instead. Shouldn’t have an influence on the crash, though. Does disabling vulkan shader precaching help with that?