Sample detection notebook downloads TLT model ,but not using it ?


I am working with the detection.ipynb provided. Stage 1.3 downloads a model (resnet18_kitti_multiclass_v1.tlt),
but it seems it is never used in the training phase ?
I searched for the tlt file in the training config file, nothing found. Am I missing something ?


I tried to use the model supplied (added it as the pretrained_model_file param).
Prepared the images to 1224 width, 384 height, 3 channels (made sure no b&W). Got this when tried to train:

Traceback (most recent call last):
File “/usr/local/bin/tlt-train-g1”, line 10, in
File “./common/”, line 24, in main
File “</usr/local/lib/python2.7/dist-packages/decorator.pyc:decorator-gen-106>”, line 2, in main
File “./drivenet/common/”, line 46, in wrapped_fn
File “./dashnet/scripts/”, line 627, in main
File “./dashnet/scripts/”, line 552, in run_experiment
File “./dashnet/scripts/”, line 457, in train_dashnet
File “./dashnet/scripts/”, line 315, in build_training_graph
File “./dashnet/model/”, line 443, in build_training_graph
File “./dashnet/model/”, line 210, in predictions_to_dict
File “./drivenet/objectives/”, line 95, in reshape_output
File “/usr/local/lib/python2.7/dist-packages/keras/engine/”, line 617, in call
output =, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/keras/layers/”, line 405, in call
return K.reshape(inputs, (K.shape(inputs)[0],) + self.target_shape)
File “/usr/local/lib/python2.7/dist-packages/keras/backend/”, line 1891, in reshape
return tf.reshape(x, shape)
File “/usr/local/lib/python2.7/dist-packages/tensorflow/python/ops/”, line 6113, in reshape
“Reshape”, tensor=tensor, shape=shape, name=name)
File “/usr/local/lib/python2.7/dist-packages/tensorflow/python/framework/”, line 787, in _apply_op_helper
File “/usr/local/lib/python2.7/dist-packages/tensorflow/python/framework/”, line 3392, in create_op
File “/usr/local/lib/python2.7/dist-packages/tensorflow/python/framework/”, line 1734, in init
File “/usr/local/lib/python2.7/dist-packages/tensorflow/python/framework/”, line 1570, in _create_c_op
raise ValueError(str(e))
ValueError: Cannot reshape a tensor with 709632 elements to shape [32,4,4,24,78] (958464 elements) for ‘reshape_1/Reshape’ (op: ‘Reshape’) with input shapes: [32,12,24,77], [5] and with input tensors computed as partial shapes: input[1] = [32,4,4,24,78].

Any ideas ?

There is a limitation where Pretrained weights cannot be imported to be trained at a different resolution. Your input size is 1224 x 384 as opposed to 1248x384 of the pretrained weights, so that may be the problem