SDK Manager and PX2

Hello!
I am trying to reflash my Nvidia Drive PX2 but after installing sdkmanager there is no option for this platform.
I have tried every version from this list- SDK Manager Downloads Archive | NVIDIA Developer but none of them have option for DRIVE PX2, versions 1.0,1.1,1.2 doesnt even let me log in to my Nvidia account.
Instructions on NVIDIA DRIVE Downloads | NVIDIA Developer led me to believe sdkmanager v0.9 would have Drive support.
How can I get sdkmanager to allow me to reflash Drive Px2?

I know this platform is no longer supported but at the time it was very expensive and I would like to continue to use it. Could you please respond?

Dear @artis.rusins,
My apologies for missing your post. May I know which version sdkm you are using?
What DRIVE OS release is on target?

As I stated in my original post, Ive tried several sdkmanager versions and I cant login to my developer account with versions until 1.2, but newer sdkm versions doesnt offer option to choose PX2. As for Drive OS, Im not sure how to check it.

Dear @artis.rusins,
Did you use ubuntu 16.04 host and also check running sdkmanager --archivedversions if you don’t see old release. Please let us know if it works?

Dear @SivaRamaKrishnaNV,
thanks for your response. I am using ubuntu 16.04 in virtual machine and sdkmanager --archivedversions allows me to select Drive PX2 platform and it is detected correctly.


But there are 2 issues. When sdkmanager downloads required packages, I get error regarding DevTools documentation

I tried to manually go to https://developer.nvidia.com/drive/secure/drive_bundles/drive_5102l_sdk_hyperion_b65/devtool_docs.zip I and succesfully downloaded required Devtool_doc.zip and placed it in …/Downloads/nvidia/sdkm_downloads but sdkmanager still cant find it and gives error.

When I try to flash board I get error:



lsusb returns:
Bus 001 Device 004: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
Bus 001 Device 003: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
so PX2 board is found by host pc. How can I resolve these issues?
Thanks!

Dear @artis.rusins,
Please share sdkm logs(~/.nvsdkm/log folder and skdm*.log files)

@SivaRamaKrishnaNV
logs.zip (52.1 KB)
sdkm-2022-09-19-11-43-24.log (261.1 KB)