Serial communication

Hello,
I’ve a problem with my uart serial communication between Jetson xavier and PC
I’ve got the following output on putty.


Can anyone provide help?

I have got an update, I switched Rx and Tx.

However, it isn’t working probably like the example in jetson hacks.

I am trying to send a string >> “best” from Xavier to my PC however, i am receiving some sort of rubbish like 5$!, the baud rate is the same.

I connected pin 8, 9 and 10 of Xavier to a (male/male rs232 cable) to (rs232 to usb converter cable) to my laptop and using PuTTy.

and the configuration is like follows:

serial_port = serial.Serial(
port="/dev/ttyTHS0",
baudrate=115200,
bytesize=serial.EIGHTBITS,
parity=serial.PARITY_NONE,
stopbits=serial.STOPBITS_ONE,
)

at first, it was ttyTHS1 like in the nano example, it didn’t work. I switched it to ttyTHS0 then the port opened however, the data sent is rubbish or encoded strangely.

Is it because of the serial console thing?, I tried the commands that disables it but nothing happened as well.

@JerryChang can you please suggest a solution?

tried gtkterm, failed as well.

There is something missing

hello mahmoud.serour,

may I have more details about using 40-pin GPIO expansion specifically for serial communication.
according to Jetson AGX Xavier Developer Kit User Guide,
you may using J501 Micro-USB connector which provides access to the UART console,
thanks

I connected pin 8 of the 40 expansion header UART_TX1 to RX of other side and pin 9 UART_RX1 to the TX of other side and connected pin 10 to make ground between both.

I can’t use pin 8 and pin 9 from the expansion header?

Is it because the UART works on 1.8V and the rs232 works from 3.3V ??

everything related to serial isn’t working correctly in the KIT, it is really frustrating, tried multiple workarounds and still same result

tried to use pyserial from the kit and the laptop and still kit sends strange characters even though the baud rate is correct.

It is definitely connection, wiring cable or level shifting.

pin 8 of Xavier Tx goes to Rx.
pin 10 of Xavier RX goes to Tx.
and common ground through pin 9.

the cable is ok, it is working between gps and pc.

I don’t know about level shifting but i assume that rs232 works from 3.3 and Xavier has level shifters from 3.3 as well.

so why the interpretation of the data either sent or received is wrong?, i even tried to send from Xavier a text and still not receiving it correctly from the other side on the laptop.

The UART at the Xavier side should be 3.3V. If half of this is 1.8V, then this would cause corrupted data. Do you have an oscilloscope? You could just verify levels are sane.