[SOLVED] deviceQuery error unkown code 30. CUDA 4.2

Hi guys! I have a hp notebook with optimus and i’ve been having a lot of trouble making CUDA 4.2 work on Unbuntu 12.04

Finally i installed nvidia-346 driver from the xorg-edgers ppa. And bumblebee and prime from the official repositories. Everything compile just right, strange thing is that, for example, youtoube won’t give the option to play the videos with HD resolution, i don’t know if it has something to do with the problem.

I followed this guide skipping the driver thing because that part was not prepared for a computer with optimus, the only thing i changed was the PATH part, making it go to nvidia_346 instead of nvidia_current.

I followed

glxspheres64 gives me +4k fps.

When i try to run deviceQuery it was telling me ‘nvidia-346-uvm’ module not found, i installed it from the same repositories.

Now it’s telling me:

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 30
-> unknown error
[deviceQuery] test results...

and i don’t now where else to search for the detailed log.

Can anybody give some light on this?


You may have a mismatched system configuration. I suggest using the runfile installer method described here:


CUDA 4.2 is very old. It will likely be easier to get things working if you install CUDA 6.5 using a runfile installer.

Thanks a lot, i reinstalled everything and it worked just fine, it gave me a big headache. Maybe i should follow your suggestion. I will be working with a program written in CUDA 4.2, will CUDA 6.5 give me trouble with that?

Generally speaking, older CUDA codes should work with newer CUDA toolkits. However there is not 100% compatibility as there are a small number of changes along the way. It shouldn’t be difficult to get a code written for CUDA 4.2 working with CUDA 6.5, however.

Wow, i’m surely trying that, thanks mate!