[solved] HP Z1 with nvidia 3000M having extremely bad performance

Hi, i have a HP Z1 workstation with a built in quadro MXM 3000M card.
The system is an updated Fedora 19, the kernel is vanilla 3.10.11, the current nvidia driver is
325.15. BUT the below problem is the same with 304.xx, 319.xx

Everything is stable but the graphics performance is VERY bad. I get about 2500fps with glxgears.
I remember MUCH higher values on a passive geforce 430. And i have been using more nvidia cards on many platforms … When using nouveau i get about 500fps.

Nvidia settings show performance level 1 (73/324/147) with maximum performance desired, level 2(450/1250/900) is never reached.

Do you have an explanation for this?
I have read in other posts about clocking/measuring clock frequency problems, any ideas about my situation here?

Thanks in advance, Hanno

First of all, glxgears is not a benchmark. Please use something more representative of a typical graphics load, such as Unigine Heaven.

Does your system have the latest BIOS update? Sometimes bugs in the BIOS can cause MXM-based systems to not be able to reach the highest performance level because information that is supposed to be in the system BIOS is not available.

If the problem still occurs or your BIOS is already up to date, please see the sticky posts about how to generate and attach an nvidia-bug-report.log.gz file.

Sure about glxgears, and sure about the BIOS. I did the latest bios upgrade and noticed, HP had a
video bios upgrade for other graphics cards (K3000M, 1000M … ) but none for mine

I tried unigine valley 1.0 with a score of 161 which seems really bad. The system seems not to rise clock
rates at all…

trying to attach a file here … :-(
Unigine_Valley_Benchmark_1.0_20130913_2323.html (2.56 KB)
nvidia-bug-report.log.gz (119 KB)

Hi again, no ideas here?
I did further test with latest linux kernels and nvidia drivers 331.13. No stability problems, no crashes BUT still a very bad performance.
I did more testing - all with GpuTest 0.5.0 - comparing the Intel HD3000 graphics and my 3000M nvidia
card using the nvidia and nouveau drivers. All work fine BUT the performance is roughly the same for all opengl stacks. (Intel is fastest by a small margin). My only conclusion is:
The is no clocking above the level 1.
I coulkdn’t find a way to force reclocking by powermizer, and there are no xconf options supporting this. nvidia-smi still gives no useful information.
Is there any way to modify the vbios? (NiBiTor doesn’t support this card)

Please - any suggestions, ideas?
nvidia-bug-report.log.gz (105 KB)

We filed bug 1369223 to track this and have reproduced the problem for investigation.

I too am seeing this same issue on my Z1 as well, using driver 331.38 under both CentOS 6 and Fedora 20. I’ve tried all sorts of xorg configs that have worked for others, but don’t seem to change a thing.

Any updates to that bug?

Updated with CentOS 6 and Fedora 20 logs
[This file was removed because it was flagged as potentially malicious] (102 KB)
f20.nvidia-bug-report.log.gz (123 KB)

Hi - i didn’t make any progress over the months, tested all kinds of kernels and nvidia drivers. Also i did a fresh install of Window-7-pro and fedora20 using fedoras kernel any my own to make sure.
It’s still my HP Z1, E3-1245 cpu (so it’s having a graphics unit when the nvidia Q3000M is not plugged in.

Today i tested all Geeks3D GpuTest 0.5.0 benchmarks using windows-7 (latest nvidia driver) and a 3.12.8 linux kernel with nvidia 331.38 ( i also tested 304.119 with slighly slower performance).
All test were done at fullscreen 2560x1440, the linux scripts were modified that way.
These are my results:

           Windows           Linux

Triangle 82288 19611
Plot3D 17293 3025
PixmarkPiano 74 13
PixmarkVolplosion 203 34
GImark 779 122
Tessmarkx8 8560 1218
Furmark 498 82

One more observation, when running the furmark in windowed mode i have a GPU utilisation of 99%, PCI bandwidth 0%, max link speed 5GT, the Temp stays at 58°C, and the performance level stays at 1(0-2 range).

What is happening here, there is a consistent ~5-fold performance loss for linux on the same
hardware and nvidia driver generation.

Any way to monitor the clock rates?
Are there any kernel/nvidia parameters i could try?
nvidia-bug-report.log.gz (101 KB)

Another point here: I too noticed reduced performance on a Q4000M. It’s especially visible in the game “Portal”, where I was able to play it very well with the recommended quality settings on 1920x1080 when it was initially released, but now it’s unplayably slow, and reducing quality to minimums doesn’t help.
A system with an old 8800GT runs very smoothly using the same settings and resolution.

I figured it out after some experimentation. The real culprit in my case is the intel_pstate cpu frequency governor. Reverting to acpi-cpufreq and enabling the performance governor makes OpenGL a lot faster. Switching away from KDE to e.g. fluxbox even lets the gpu reach maximum performance level (i.e. when KDE is running, setting “prefer maximum performance” in nvidia-settings sets at most performance level 1 (of 3). in fluxbox level 3 is immediately set and it stays there. kwin compositing and effects are all disabled).

Nice suggestion, i tested again with a kernwl using acpi-cpufrequ and performance governor only so this should be safe. BUT - all benchmarking results didn’t change in a significant way.
Also i could get not get it to level 3 (still testing in gnome3).
Could you prove your findings with benchmarking???
What kind of distro/kernel are you using, or could you post a “bug-report”?

Thanks hanno

Hi again, after your suggestions i did more testing and at last found something VERY interesting.
Still using fedora20, gnome3.

But i tested some older kernels from linux.org and

**** 3.4.77 runs just perfect with 304.119
First time ever performance levels behave as expected and all benchmarks are as fast as when i tested under windows7!

So nvidia people, what else do you need to understand what is happening?

driver 331.38, 64bit kernels 3.12.9 and 3.14-rc0. As said, with CPU really maxed out by acpi-cpufreq and performance governor opengl is really fast.

I also noticed powermizer is stuck on level 1 with linux >=3.13.

I think your problem is specific to your Q3000M, which may indeed be a regression in the driver.
At least on my system one bottleneck was CPU scaling, the other now is powermizer not working right
on newest linux kernels.

Hmmh, i also think it’s rather specific. I have not observed it at any time before on other comps. It’s the HP Z1 and it affects both the Q3000M and the Q1000M - i also tested that. All benchmarks show a consistent performance

  1. For kernels 3.10 - 3.12.9 both graphics cards produce results that don’t differ much and are not much better with the nvidia driver 331.38 ( this doesn’t matter as all tested drives since 30* had the same problem) than using the nouveau.

  2. Tuning cpu governors doesn’t help really, maybe a few % improvement.

  3. I tried acpi=off acpi=noirq acpi=strict and nopat kernel options on 3.12.9, they don’t make a difference nvidia-wise.

  4. When using a 3.4.77 driver the situation changes dramatically. The Q1000Ms performance is 2-3 times faster, the Q3000M ~5times faster depending on the benchmark.

  5. I also see this performance boot with darktable, this foto application uses opencl for processing as an option, it also shows the same 3-5-fold performance gain

  6. These observations are independent of the GUI, i tested gnome3 and xfce.

  7. i compiled a 3.12.9 kernel without intels cpu clocking pdriver, this didn’t change anything.

  8. The performnce level shown in nvidia-setting correspond to the above observations. Level 2 is easily taken in ondemand mode whenever i do something ‘relevant’ ONLY with the 3.4.77 kernel.

So what could this be related to?
It really seems to be a question of prohibited upclocking in recent kernels.

More or new ideas?
“goldleaf” what kernel is centos using?


CentOS 6.5 uses the 2.6 kernel (it was 2.6.35, if I remember right). Fedora 20 is 3.12.8 at the moment. I’m seeing the problem using a GTX 670M in my Z1.

Could we get an update on whether the source of this regression has been found? Thanks so much!

I did some more testing, no problems with any <=3.7.10 vanilla kernels, later kernels don’t work right so far despite switching off intel pstate and more. ATM i’m stunned …

Reading you are using a 670M in the Z1 (self built?)

I don’t know what centos added to the 2.6 kernel, there must be lots of mods as in rh-enterprise kernels.
I will try tro find out more, anyway, if you are interested in a working 3.7.10 kernel .config to make your own kernel let me know.

Yeah, the CentOS kernel is the same as the RHEL one. I’ve never run using an older kernel; how does that affect the stability of the rest of Fedora (i.e. Gnome-Shell) in your system?

Other than speed issues, I like using F20/Gnome-Shell; but I may end up just moving over to CentOS to get the best performance I can in Houdini (unless using the 3.7 kernel is stable).

Thanks for sharing the wisdom!

Using the old kernel is not so much a problem, it’s more security concerns i have. The 3.4 kernels are longterm and thus safer to use but they had no support for usb3 on hpz1 and didn’t support most current usb dvb devices. I have both kernels installed here, i have not observed any problem yet.

Just a little update, as I’ve finally had some success on my Z1. Here are the versions that let me get full performance on my Z1 + GTX 670M:

  • Debian Wheezy 7.4 (3.2.0-4-amd64 kernel)
  • Nvidia 334.21 Driver

With these versions, I can set PowerMizer to maximum and it uses the card completely. I’m pretty sure it has more to do with the kernel version than the driver (this same driver had the throttled performance under Jessie and Ubuntu 14.04 beta). So if you’re in a similar situation with a Z1, give Debian Wheezy a go!

Thanks to those who took the time to offer advice/consolation!

Hi to all Z1 owners, finally there is a fix tothis problem.
Until now i had to use the 3.4 kernels and they were performing fine, clocking support lead to 5-fold
performance compared to later kernel.

Thanks to HP this is fixed now - tested on ubuntu 14.04 and fedora 20 with nvidia drivers 337.25 and 331.79.

What has to be done by you? Just install the latest system BIOS :-)

jhs, Is this issue resolved for you with latest sbios? Unigine score is improved?