(SOLVED) Jetson TK1 stuck at boot after flash L4T r19.3

I followed instructions how to flash and I havent modified anything. Everything flashed successfully from Ubuntu 14.04 amd64 host pc. Now when I boot it every time its stuck at standard boot command line and I cant type anything. last line is … —[ end trace c027b283e120f07e ]—

Please help me to get it boot up to command line from which I can type.

Thanks!

Here is a screenshot of the screen which is stuck:

Well, a kernel Oops means it did transfer control from boot loader to kernel. So at least part of the flash worked, and Jetson itself has not failed.

So, since we know R19.3 works on Jetson, the question is the flash configuration itself. What was your flash.sh command line?

If I understood you well…

Screenshots of terminal:

Ok, the very first line was the one to look at:

flash.sh -S 8GiB mmcblk0p1

The last lines were:

*** The target ardbeg has been flashed successfully. ***
Reset the board to boot from internal eMMC.

Personally, when I flashed I used a larger size, my -S 8GiB was instead -S 14GiB (the largest I could use without exceeding eMMC). I don’t think this should have mattered. I also used u-boot, but this too should not matter.

The last line says the flash worked, and there was no error from udev needing /dev/loop0. So I’m inclined to believe that the flash was correct, but the pre-flash setup was incorrect.

There was an apply_binaries.sh script to run prior to the flash.sh. What did you do for setup preparation?

I downloaded sample file system and l4t 47mb package, extracted them using gui, put extracted sample file system in rootfs.
In terminal i cd’d to rootfs directory and ran binaries.sh command as root. Thats it.

Try this…delete your entire L4T that you unpacked before, but unpack it again making sure you always do this as root or sudo root, and preserve file permissions in tar (in Ubuntu, sudo -s is convenient), e.g.:

bunzip2 < Tegra_Linux_Sample-Root-Filesystem_R19.3.0_armhf.tbz2 | tar xvp
   ...

When you use apply_binaries.sh, be sure to use root again.

Make sure your micro-B USB is seated, disconnect any unused USB devices (e.g., mouse and keyboard not needed on Jetson itself during flash), and flash again. Try more space:

flash.sh -S 14GiB jetson-tk1 mmcblk0p1

If you want to show logs, you can probably just mouse copy and paste (screenshots are the hard way to do it). If you have “tee” try:

flash.sh -S 14GiB jetson-tk1 mmcblk0p1 <b><i>2>&1 | tee flash.log</i></b>

Thanks! I’ll try that right now, and I’ll plug in Sd card (8gb)

For SD card use mmcblk1p1 instead of mmcblk0p1.

If you are flashing an entire system to an 8 GB SD, this might be a cause of failure. The root file system itself is near 8 GB. I would not use an 8 GB SD for anything other than mounting later or for flashing boot loader and kernel.

Oh, dont worry, I wont flash the system on sd card. I just saw your post in another thread. Anyway I’m redownloading files now. Terminal failed to untar. That might be the problem, even though I’ve redownloaded files before already.

One cause for a tar unpack failure would be lack of permissions…for example, it may be blocked when producing a device special file. Permissions on the rootfs should be preserved as well from unpacking…the -p option of tar.

Could I use Thunar file manager as root? I’m also having these files on ntfs shared partition. Maybe I should increase Ubuntu partition size and do all that on ext4?

If Thunar can preserve permissions and create needed device special files, etc., it shouldn’t differ from directly using tar. Preserving permissions and being able to create device special files should not be considered optional.

NTFS is incapable of creating the linux file permissions, and has a high probability of causing the failure. Switch to ext4, try between 10 and 14 GiB on -S…I’ve tested 14 GiB.

Ok. I’m simply going to increase ext4 to 30gb. I can have use of that for other things, too. I completely forgot ntfs could be the problem. Jetson might just boot properly after I’ve done everything you mentioned, hopefully.

I reflashed and now I get error "Mount failed for selinux on /sys/fs/selinux: No such file or directory

What I did:

extracted files in home directory (ext4), put extracted files (bin, boot, dev etc.) into rootfs.
Then I ran (as root) apply_binaries.sh, after that I started flashing but choose 14GiB this time.

mislav@mislav-Aspire-5830G:~$ cd /home/mislav/Linux_for_Tegra
mislav@mislav-Aspire-5830G:~/Linux_for_Tegra$ sudo ./apply_binaries.sh
[sudo] password for mislav: 
Using rootfs directory of: /home/mislav/Linux_for_Tegra/rootfs
Extracting the NVIDIA user space components to /home/mislav/Linux_for_Tegra/rootfs
Extracting the NVIDIA gst test applications to /home/mislav/Linux_for_Tegra/rootfs
Extracting the configuration files for the supplied root filesystem to /home/mislav/Linux_for_Tegra/rootfs
Creating a symbolic link nvgstplayer pointing to nvgstplayer-0.10
Creating a symbolic link nvgstcapture pointing to nvgstcapture-0.10
Adding symlink /home/mislav/Linux_for_Tegra/rootfs/usr/lib/arm-linux-gnueabihf/tegra/libcuda.so --> /home/mislav/Linux_for_Tegra/rootfs/usr/lib/arm-linux-gnueabihf/tegra/libcuda.so.1.1
Adding symlink /home/mislav/Linux_for_Tegra/rootfs/usr/lib/arm-linux-gnueabihf/libcuda.so --> /home/mislav/Linux_for_Tegra/rootfs/usr/lib/arm-linux-gnueabihf/tegra/libcuda.so
Extracting the firmwares and kernel modules to /home/mislav/Linux_for_Tegra/rootfs
Installing vmlinux.uimg into /home/mislav/Linux_for_Tegra/rootfs/boot
Installing zImage into /home/mislav/Linux_for_Tegra/rootfs/boot
Installing jetson-tk1_extlinux.conf* into /home/mislav/Linux_for_Tegra/rootfs/boot
Installing the board *.dtb files into /home/mislav/Linux_for_Tegra/rootfs/boot
Success!
mislav@mislav-Aspire-5830G:~/Linux_for_Tegra$ sudo ./flash.sh -S 14GiB jetson-tk1  mmcblk0p1
copying dtbfile(/home/mislav/Linux_for_Tegra/kernel/dtb/tegra124-pm375.dtb) to tegra124-pm375.dtb... done.
Making system.img... /home/mislav/Linux_for_Tegra/rootfs 15032385536 
	populating rootfs from /home/mislav/Linux_for_Tegra/rootfs... done.
	Sync'ing... done.
System.img built successfully. 
copying bctfile(/home/mislav/Linux_for_Tegra/bootloader/ardbeg/BCT/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.cfg) to bct.cfg... done.
copying cfgfile(/home/mislav/Linux_for_Tegra/bootloader/ardbeg/cfg/gnu_linux_fastboot_emmc_full.cfg) to flash.cfg... done.
creating gpt(ppt.img)... 
*** GPT Parameters ***
device size -------------- 15766388736
bootpart size ------------ 8388608
userpart size ------------ 15758000128
Erase Block Size --------- 2097152
sector size -------------- 4096
Partition Config file ---- flash.cfg
Visible partition flag --- GP1
Primary GPT output ------- PPT->ppt.img
Secondary GPT output ----- GPT->gpt.img
Target device name ------- none

*** PARTITION LAYOUT(16 partitions) ***
[     BCT] BH            0        16383       8.0MiB 
[     PPT] UH            0         4095       2.0MiB ppt.img
[      PT] UH         4096         8191       2.0MiB 
[     EBT] UH         8192        16383       4.0MiB fastboot.bin
[     LNX] UH        16384        32767       8.0MiB boot.img
[     SOS] UH        32768        45055       6.0MiB 
[     GP1] UH        45056        49151       2.0MiB 
[     APP] UV        49152     29409279   14336.0MiB system.img
[     DTB] UV     29409280     29417471       4.0MiB tegra124-pm375.dtb
[     EFI] UV     29417472     29548543      64.0MiB 
[     USP] UV     29548544     29556735       4.0MiB 
[     TP1] UV     29556736     29564927       4.0MiB 
[     TP2] UV     29564928     29573119       4.0MiB 
[     TP3] UV     29573120     29581311       4.0MiB 
[     UDA] UV     29581312     30773247     582.0MiB 
[     GPT] UH     30773248     30777343       2.0MiB gpt.img
done.
copying bootloader(/home/mislav/Linux_for_Tegra/bootloader/ardbeg/fastboot.bin)... done.
Bootloader(/home/mislav/Linux_for_Tegra/bootloader/ardbeg/fastboot.bin) used as flasher.
Existing flash application(/home/mislav/Linux_for_Tegra/bootloader/nvflash) reused.
making zero initrd... 
done.
Making Boot image... done
*** Flashing target device started. ***
./nvflash --bct bct.cfg --setbct --configfile flash.cfg --create --bl fastboot.bin --odmdata 0x6009C000 --go
Nvflash 4.13.0000 started
chip uid from BR is: 0x34001001740970422400000007ff80c0
rcm version 0X400001
Skipping BoardID read at miniloader level
System Information:
   chip name: unknown
   chip id: 0x40 major: 1 minor: 1
   chip sku: 0x81
   chip uid: 0x00000001740970422400000007ff80c0
   macrovision: disabled
   hdcp: enabled
   jtag: enabled
   sbk burned: false
   board id: 0
   warranty fuse: 0
   dk burned: true
   boot device: emmc
   operating mode: 3
   device config strap: 0
   device config fuse: 0
   sdram config strap: 3

RCM communication completed
BCT sent successfully
odm data: 0x6009c000
downloading bootloader -- load address: 0x80108000 entry point: 0x80108000
sending file: fastboot.bin
- 900492/900492 bytes sent
fastboot.bin sent successfully
waiting for bootloader to initialize
bootloader downloaded successfully
ML execution and Cpu Handover took 1 Secs
Partition backup took 0 Secs
setting device: 2 3
deleting device partitions
creating partition: BCT
creating partition: PPT
creating partition: PT
creating partition: EBT
creating partition: LNX
creating partition: SOS
creating partition: GP1
creating partition: APP
creating partition: DTB
creating partition: EFI
creating partition: USP
creating partition: TP1
creating partition: TP2
creating partition: TP3
creating partition: UDA
creating partition: GPT
sending file: ppt.img
\ 2097152/2097152 bytes sent
ppt.img sent successfully
padded 4 bytes to bootloader
sending file: fastboot.bin
- 900496/900496 bytes sent
fastboot.bin sent successfully
sending file: boot.img
\ 5912576/5912576 bytes sent
boot.img sent successfully
sending file: system.img
/ 15032385536/15032385536 bytes sent
system.img sent successfully
sending file: tegra124-pm375.dtb
- 34678/34678 bytes sent
tegra124-pm375.dtb sent successfully
sending file: gpt.img
\ 2097152/2097152 bytes sent
gpt.img sent successfully
Create, format and download  took 2838 Secs
Time taken for flashing 2839 Secs
*** The target ardbeg has been flashed successfully. ***
Reset the board to boot from internal eMMC.

mislav@mislav-Aspire-5830G:~/Linux_for_Tegra$ ^C
mislav@mislav-Aspire-5830G:~/Linux_for_Tegra$

SOLVED!!! System now boots properly.

Big thanks to @linuxdev

Hi,

Flashing the custom board based on Jetson TK1, failed to flash using CFG_600MHz.cfg

*** Flashing target device started. ***
./nvflash --boardid 0x177 0x00 0x03 --bct CFG_600MHz.cfg --setbct --configfile flash.cfg --create --bl fastboot.bin --odmdata 0x6209C000 --go
Nvflash 4.13.0000 started
BR_CID: 0x340010017411410310000000140085c0
rcm version 0X400001
Skipping BoardID read at miniloader level
System Information:
chip name: unknown
chip id: 0x40 major: 1 minor: 1
chip sku: 0x0
chip uid: 0x000000017411410310000000140085c0
macrovision: disabled
hdcp: disabled
jtag: disabled
sbk burned: false
board id: 0
warranty fuse: 0
dk burned: false
boot device: emmc
operating mode: 3
device config strap: 0
device config fuse: 0
sdram config strap: 0

RCM communication completed
auxInfo->NCTBoardInfo->proc_board_id is 375
auxInfo->NCTBoardInfo->proc_sku is 0
auxInfo->NCTBoardInfo->proc_fab is 3
BCT sent successfully
sending file: tegra124-xxx-yyy.dtb

Here it got hanged…

Please help out to resolve the issue.