SPI not working on JetPack 4.4

I connected pins 19 and 21 on the J41 expansion header and ran the SPI loopback test as described here. I get 00’s in readout.

I did try to enable SPI following this guide, but I assume I might’ve done something wrong at some point.

  • Ran /opt/nvidia/jetson-io/jetson-io.py to configure the J40 expansion header and exported the new device tree overlay.
  • Compiled the device tree overlay with

dtc -I dtb -O dts -o my-overlay.dts /boot/tegra210-p3448-0000-p3449-0000-b00-user-custom.dtbo

and

dtc -O dtb -o my-overlay.dtbo -@ my-overlay.dts

  • Put the my-overlay.dtbo file in /boot and rebooted.
    In addition to SPI still not working, the jetson-io.py configuration tool now shuts down a second or two after launch.

I take it there’s a way to properly enable SPI in JetPack 4.4, but I can’t seem to find out how.

Hello Trueshadow97
Look at Xavier agx spi jetpack 4.4 and in that post we had discussed.
Use PI loopback test is working in Jetson nano with JETPACK 4.4
https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/hw_setup_jetson_io.html and follow GUI method till reboot. The same work flow takes care of things well and leading to SPIDEV_test.c work well … best regards //jk

1 Like

I changed the SPI mode from 3 to 1, as was suggested in the post you linked, and the SPI still doesn’t work.

So I removed the my-overlay.dtbo and tegra210-p3448-0000-p3449-0000-b00-user-custom.dtbo from /boot and rebooted. The Jetson-IO config tool worked again, but instead of exporting the device tree overlay file as suggested in the guide I linked, I just chose the “Reboot and reconfigure pins” option. Worked like a charm.

good, does it mean that it is working ( spi loop back) well

Yes, otherwise I wouldn’t mark this as a solution. Thank you still for the advice that led me to figuring this out.

welcome… may be next step move away from Loopback and try with another SPI Slave device and work with Jetson Nano…