Jetson nano spi not workiing

Hi All,

I have issue with jetson nano spi, I connect the pin 19 with pin 21 in the 40pin header, and enable spi via jetson io, with the spidev_test, I can receive anything.

jetson version

sudo cat /sys/kernel/debug/tegra_gpio

sudo /opt/nvidia/jetson-io/ -l enabled

please note, same hardware(jetson), I used the 4.6.1 version before, which spi is working, but not stable, but after I update to 4.6.4, then spi is not working anymore, even I go back to 4.6.1, still not working.

Hi guopeng.sun,

Could you refer to the following thread to verify SPI loopback test step-by-step for Jetson Nano with JP4.6.4?
Jetson Nano SPI Bus Not Working - #10 by KevinFFF

Hi Kevin,

I also need some more clear steps related to step2:

“Step 2. Remove GPIO usage of SPI pins”

I’m using the official jetson nano B01, and should use the “tegra210-p3448-0000-p3449-0000-b00.dts”

But if I decompile this dtb file to a dts file, I could not find anything start with “TEGRA_GPIO”, also I donwload the source code, but could not find any dtsi file,

and below you could find the output:
sudo cat /sys/kernel/debug/tegra_pinctrl_reg | grep -i spi

Hi Kevin,

I justed checked with Yahboom engineer, they also tried on their own jetson nano b01, the spi is nor working in loop back mode.

Could you please help check on your side, 4.6.1 or 4.6.4, any is ok, if it’s working or not?

If it’s working with some modification needed, could you please help prapare a shell script or something similar that user can easily do the changes, or you can share the correct dts/dtb file?
Because we are application developer, we really don’t have much know-how on linux device driver/ device tree staff.

All we need is a clear step on what ever jetson pack, to make the SPI and mcp2515 working, could you please help check and support to provide a detial guideline, thanks.

This is compiled dtb and would be a little different from the original device tree after decompile.
Please refer to the following thread to modify the decompiled dts and assemble it back to dtb.
Problem with SPI in Jetson Nano - #14 by KevinFFF

You could also share the full flash log for further check.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.