Steam games won't launch on nvidia card despite adding relevant parameters

I have a Fedora 33 laptop with optimus graphics (intel hd630+gtx 1050 ti).

I installed steam and then tried to play Skyrim but i noticed that the performance was terrible. Upon checking the dxvk hud i noticed it was running on the intel card despite me adding the relevant parameters
to game launch settings.

I then tried running
__NV_PRIME_RENDER_OFFLOAD=1 __VK_LAYER_NV_optimus=NVIDIA_only vkcube” and it seems to throw this weird error: “INTEL-MESA: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0”. However launching nvidia-smi shows that there is a process called vkcube running on the nvidia card.

__NV_PRIME_RENDER_OFFLOAD_PROVIDER=NVIDIA-G0 __GLX_VENDOR_LIBRARY_NAME=nvidia glxgears works and a process called glxgears appears when launching nvidia-smi.

I don’t really know what’s broken given that everything seemed to work fine until now.

kernel v 5.9.8
nvidia driver 455.45.01 (from rpmfusion)
Xorg 1.20.9

Secure boot is disabled, tried reinstalling the nvidia driver and it didn’t fix my issue.

Edit: I added the nvidia bug report. I changed the username and device name for privacy. The following parameters were added to skyrim launch settings:


nvidia-bug-report.log (2.3 MB)

Add VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json

If your using proton 5.13 - there’s some kind of regression that causes VK_ICD_FILENAMES and LID_LIBRARY_PATH to be overridden, so you have to temporarily delete (or move) the non nvidia configs in /usr/share/vulkan/icd.d.

That seemed to do it. Using VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json and an older version of proton made it work. Thank you!

edit: is this argument (VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json) required for future versions of proton as well or only until 5.13 is patched?