Support for Optimus

You are gonna love it, select non-free when you run the LIVE session so during install it will set you up with Nvidia.

Interesting, I kept hearing Manjaro and I didn’t realize it was an Arch-based distribution until now. For what it’s worth. With kernel 3.12-rc3 (probably the newest 3.12-rc4 works also), my Toshiba P50 laptop works with the Intel 7260 AC card decently well. I had to patch the nvidia 325.15 drivers to compile on kernel 3.12, but after this, bumblebee works suceesfully on Ubuntu 13.10 GNOME Beta 1 updated to the latest packages.

I actually had it among the distros on the USB pen. In live-session now. I really like the look and feel of it. However, I have some major issues with it. I got two backgounds, seems to be in two different resolutions, where the small one overlap the black backgroung on the external screen. The screens seems to be linked, I can not access the other screen, but is seems like it has the same resolution as the big screen, and is cropped so it only shows part of the desktop. I am not sure, but it might be that some of these issues are related to being live-session.

It is very nice to see that Steam is installed as default, as well as I get nVidia settings, but is it so that the nVidia card will not work before it is installed?

I get this form the terminal:

[manjaro@manjaro ~] lsmod | egrep "nouveau|nvidia|vesa" [manjaro@manjaro ~] glxgears
305 frames in 5.0 seconds = 60.834 FPS
301 frames in 5.0 seconds = 60.161 FPS
301 frames in 5.0 seconds = 60.162 FPS
[manjaro@manjaro ~]$ optirun glxgears
307 frames in 5.0 seconds = 61.206 FPS
301 frames in 5.0 seconds = 60.157 FPS
301 frames in 5.0 seconds = 60.163 FPS

Number of frames should be way over that if the nVidia card is used. I got it to work in Ubuntu somewhat (and that gave a considerably higher amount of frames per second), although still had issues as well as problems with running games in Steam or PlayOnLinux with the nVidia card.

When I try to open nvidia-settings:

"You do not appear to be using NVIDIA X driver. Please edit you X configuration file … "

Trying to run this command:

"[manjaro@manjaro ~]$ nvidia-xconfig

WARNING: Unable to locate/open X configuration file."

Please install and update it, ,then install Kernel 3.11 and it works swell. You are also running free drivers and not nvidia. Boot in non-free mode.

optirun glxgears
302 frames in 5.0 seconds = 60.218 FPS
302 frames in 5.0 seconds = 60.302 FPS
302 frames in 5.0 seconds = 60.297 FPS
302 frames in 5.0 seconds = 60.304 FPS

I did boot in non-free mode I believe. At least I got youtube working, Iced Tea was active, and so on. Will give it another shot when I have the time and see how it works when it is installed.

I did installed Manjaro on the 10". Works well there, seems like a nice distribution overall. Also being with most the stuff I need out of the box.

Please download latest edition before you give it another spin. In my case all my laptops with nvidia card work well, even one old netbook with ATI works good.

Shouldn’t be that old though, this is the information in the terminal.

System:    Host: manjaro Kernel: 3.10.11-1-MANJARO i686 (32 bit) Desktop: Xfce 4.10.2 Distro: ManjaroLinux 0.8.7 Ascella

Since it has the 3.10 kernel, I believe it should be 0.8.7.1 as well.

Works perfectly well here too, although this laptop is not mine.

There is still one software I use Windows for, but if I get Manjaro to work perfectly, it won’t be a problem. But installing it now, and potentially break the Windows installation, would be tedious if it does not work. If it however does work perfectly, I wouldn’t really care much about Windows at all.

Search AUR if you can’t find in Manjaro, also install thermald from AUR and TLP, thermald keeps temps down on par with Windows while TLP keeps the battery consumption on level with Windows.

You get the same frame rate because Sync to VBlank is on:


call it as:

The link above explains how to disable sync to vblank via other means as well.


You get the error message with nvidia-settings because you have to call it like so:

where :8 is the default Bumblebee X server.

Thank you :)

9590 frames in 5.0 seconds = 1917.909 FPS
9556 frames in 5.0 seconds = 1911.144 FPS
9587 frames in 5.0 seconds = 1917.297 FPS
9545 frames in 5.0 seconds = 1908.909 FPS

Is it anything else I need to do to play games through Steam?

I try to open up Metro: Last Night. The screen turn black for a few milliseconds before it seems to get forced shut down. And nothing more happens.

I have these packages installed in Manjaro, which also was preinstalled:

bumblebee 3.2.1-4
primus 20121027-1
linux310-nvidia 325.15-9
nvidia-utils 325.15-1
mhwd-nvidia 325.15-1
mhwd-nvidia-legacy 304.108-1

Ok, this is weird. Why do I get higher FPS without using optirun than with in that command?

glxgears:
305 frames in 5.0 seconds = 60.942 FPS
301 frames in 5.0 seconds = 60.161 FPS
301 frames in 5.0 seconds = 60.161 FPS

vblank_mode=0 glxgears:
26570 frames in 5.0 seconds = 5313.842 FPS
26603 frames in 5.0 seconds = 5320.517 FPS
26801 frames in 5.0 seconds = 5360.175 FPS

vblank_mode=0 primusrun glxgears (same with optirun):
2987 frames in 5.0 seconds = 597.397 FPS
2998 frames in 5.0 seconds = 599.426 FPS
3022 frames in 5.0 seconds = 604.340 FPS

Also, clicking OpenGL / GLX Information in nvidia setting manager crashes the manager and gives this message:

Error: nConfigOptions (13) does not match the actual number of options in
__driConfigOptions (12).
nvidia-settings: …/…/…/…/src/mesa/drivers/dri/common/xmlconfig.c:1024: driQueryOptionb: Assertion `cache->info[i].name != ((void *)0)’ failed.

The exact same thing happens here. I get higher framerate without optirun than with when using wblank_mode=0. Without vbalnk_mode the framerates are exactly the same with or without optirun. There are no error messages when launching optirun. I’m on Ubuntu 13.10 using the 3.12.1 kernel and nvidia 331.20 on a GT 750M card.

I also get the same crash and error message when trying to open the "OpenGL/GLX tab in nvidia-settings manager.

The additional frames when sync to vblank is off is normal. You’re just proving 3D acceleration works when you disable it. See:

http://ubuntuforums.org/showthread.php?t=1537858
http://superuser.com/questions/485393/sync-to-vblank-nvidia-x-server-settings

I get some variation of the same error when I try to open the OpenGL tab on my optimus laptop as well… not sure what the culprit is there, perhaps nvidia-settings expects more configuration options from the :8 server than it’s actually getting, as inferred to by the error message, but not sure what the culprit there is… that might be something that the bumblebee people would know.

Optirun is very useful there, where is a lot of processing - for example games with high requirements. You can see much higher framerates when you play a game with good graphics.

In glxgears there isn’t many items to render… Bumblebee/primus aren’t as good (or cannot be) and they lose time to copy rendered image, synchronisation etc.

Even in glxspheres I often get better result using intel HD4000 than my nvidia 635M. But when I play Nexuiz, NFS Carbon or others, I have about 2-2.5x more fps.

When I run something in PS2 emulator, then native optimus support (using new drivers, xrandr 1.4 etc) is much better. In other cases bumblebee and primus are great.

Run glxgears using optirun simply doesn’t have sense ;-)