Suspend/resume freeze with 460, but works with 460-server

Hoping this might be helpful in understanding the suspend/resume freeze bug.

I tried a lot of versions of the linux nvidia driver, and they all froze on resume.

The last one I tried was 460, and yes it froze. I saw a post about 460-server not freezing, and it indeed works perfectly. OpenCL is happy with it too, which is very important for me. So the difference between the server version and the normal version is what causes the bug in my particular case. If you want more info I’ll be happy to provide it.

Linux Mint Tricia (19.3)
Kernel: 5.0.0-32-generic #34~18.04.2-Ubuntu SMP Thu Oct 10 10:36:02 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Lenovo legion y7000
CPU: Quad Core Intel Core i5-8300H (-MT MCP-) speed/min/max: 800/800/4000 MHz
Graphics: Device-1: Intel driver: i915 v: kernel
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia v: 460.91.03
Display: server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 460.91.03