System running in low-graphics mode after flashing image


I already searched the forum but could not find a solution to my exact problem. I have 3 Jetson which I would like to run the same system. I cloned the image of the fully set up Jetson via

sudo ./ -r -k APP -G my_backup.img jetson-tx2 mmcblk0p1


I renamed the image to “bootloader/system.img” and flashed the other two devices via

sudo ./ -r -k APP jetson-tx2 mmcblk0p1

I flashed both devices with the exact same image but on one of them I received the “The system is running in low-graphics mode” error. The file system of the host is ext4 with the correct permissions since flashing worked correctly previously (also on the currently not working device). I also made sure that there is enough space when I created the image and even cloned a working Jetson device and tried flashing again, but the third Jetson still shows the error message.

I would appreciate any kind of help.
If you need any additional information please let me know!


Your steps are basically correct, but keep in mind that a cloned rootfs may be intended for a particular release…e.g., you can’t mix a rootfs from R27.0.1 (shipped version) and R28.2. So if you restored from clone and this happens the first thing I am suspicious of is that the destination of the clone is from a different release. You’ll need to flash the entire Jetson with the same release from which the clone was on.

If you have a rootfs from R28.2 this isn’t a problem. With your clone in place of system.img as you have done:

sudo ./ -r jetson-tx2 mmcblk0p1

(leave out the “-k APP”…it’ll still use your clone but it’ll put the other files in place as well)

Note that if you have a clone from an older version then you may have to flash normally and then update manually (e.g., you can loopback mount the raw image clone and read files…standard tools like rsync work).

What release is your clone from?

I used once to get “The system is running in low-graphics mode” issue;
What I did was to set manually resolutions, that as far as I remember wouldn’t work until restart of the system, then worked.
I mean that it wasn’t possible to set display resolution via GUI [Settings - Display], then I got to instructions on how to set resolutions from command line and somehow the issue got resolved after all.


The cloned image is from a Jetson flashed with Jetpack 3.1 (R28.1) and the other Jetson was previously flashed with Jetpack 3.2 (R28.2). Although I was sure the other device (the one that I was able to flash successfully) was also running R28.2 I might be mistaken. I did not think about the Rootfs. I will definitely try your suggestion and report my results. Thank you!


I already tried resolving the issue manually but could not get it fixed. I might have to try again though, since I did not put too much effort into it.

Flashing the Jetson with the other Rootfs version and then flashing my cloned image worked perfectly. Thank you for your help!