Technical problems with the Jetson Orin NX 16GB

Good evening, I purchased a Jetson Orin NX 16GB from seed studio.
I use the card to make inference using Yolo.
With a Jetson Orin Nano (less powerful) I get a real time result of 60 milliseconds per frame, while using the Jetson Orin NX (more powerful) I get a real time result of 100 milliseconds per frame
(same camera connected and same program)
Using jetson-stats I can see the following statistics:

  • 95%/100% GPU usage
  • 8GB RAM used on 16GB
  • 4 CPU cores are turned off (before, after and during program execution)

jetpack: 5.1.1 for both cards.

The libraries I use are the same for both cards:

  • opencv 4.5.4
    -CUDA 11.8.89
    -python 3.8.10
    -torch 2.0.0
    -torchvision 0.15.1
    (the most significant)

I wanted to ask for your help to understand first of all why there are 4 out of 8 CPU cores constantly turned off and if they can be activated in some way.
And above all why a card with approximately double the power compared to the Orin Nano makes an inference at double the milliseconds per frame compared to our Orin Nano (following the factory statistics I should find a lower result, therefore much less than 60 milliseconds per frame with the Orin NX).
Are there drivers to install that are not present in the jetpack installation?
What should I do/check/change/install?
I really don’t know how to explain myself and what to do.
I hope someone can help me, I really need it, sorry if it seems trivial, but I’m a beginner.
Thanks a lot in advance to anyone who will help me!


CPU number is related to the power mode.
You can set nvpmodel to MAXN or 25W to enable 8 CPUs. More info can be found below:

How do you infer the YOLO model?
If TensorRT acceleration is adopted, please check if you have recompiled the TensorRT engine for the OrinNX device.
The acceleration is hardware based so please recompile it if the environment has changed.


Hi, thanks so much for replying!
I saw the link for the power mode that you provided me, are you saying that could be the problem?
Because the code is a py script not a .bat so in theory it should recompile the code at each launch and I don’t use acceleration on the TensorRT model in either of the two tabs, so it shouldn’t create speed differences. (I didn’t know about its existence, clearly now I will implement it on both anyway)
Thanks again in advance for your reply and help!


You can set the nvpmodel to MANX to turn on all the CPUs.
Please try below command to maximize the perf for Orin NX.

$ sudo nvpmodel -m 0
$ sudo jetson_clocks


Thanks again! I’ll try as soon as possible.