TensorRT 3 Wrong output shape with ConvTranspose and Tensorflow

I tried to use a froozen tensorflow model with TensorRT. Conversion to UFF format works, but initialicing the engine with uff_to_trt_engine fails in the last conv2dtranspose layer with

Output shape of UFF ConvTranspose is wrong

The Tensorflow model was trained with channels last, but the error is very inspecific on what the incorrect shape looks like and how this was determined.
If for helping additional information is needed I can provide it.

Thanks a lot in advance for your help.


I am interested to know if this problem was solved.

I have the same problem:

“Output shape of UFF ConvTranspose is wrong”
How do I know what should be the shape?

Is there anywhere an example of the use of the ConvTranspose layer?

I am using tensorflow, tf.nn.conv2d_transpose,

the execution in tensorflow works, the uff parsing works, but then it cannot generate the engine.

I set the output shape that makes sense in tensorflow and I dont understand why this would be wrong in tensorRT…

I tried with both padding conventions as I already had to fix that for the conv2d layers, but for this one nothing works.

Thank you for your help.


I have this problem to
Is there any update for this error?

Is there another upscale layer that works in tensorrt?

Thank you.


Also waiting for a workable way to do upsampling.

Is there any help?

Thanks a lot.


I have same request to implement unsampling operation in TRT, is anyone have did it?

Thanks a lot